mashuska
?>

Известны , полученные студентами за контрольную работу. вычислить максимальный . написать программу в паскале авс.net

Информатика

Ответы

larson96
Program maxim;     const n=15 {15 студентов};     var a: array[1..n] of integer;         i,max: integer;     begin    randomize; for i: =1 to n do begin    a[i]: =random(10){кол-во до 15};     write (a[i],'   ');     end;     max: =a[1];     for i: =2 to n do begin    if a[i]> max then max: =a[i];     end;       writeln;       writeln (max);     end.
Раисовна878
Количество информации как мера уменьшения неопределенности  (вероятностный подход)  с точки зрения отдельного человека, ценность информации определяется тем, насколько она проясняет для него какой-либо вопрос, то есть уменьшает неопределенность ситуации. при этом количество одной и той же информации может быть оценено различными людьми по-разному. для объективного измерения количества информации необходимо формализовать .  будем считать события равновозможными, если мы не располагаем заранее никакой информацией (статистическими данными, логическими умозаключениями и т. о том, что шансы одного из событий выше или ниже, чем шансы любого другого. при этом имеется в виду, что в результате опыта обязательно наступит какое-либо событие и притом только одно.  так, например, при подбрасывании монеты выпадение орла или решки можно считать равновозможными событиями, предполагая монету идеальной, то есть исключив из рассмотрения возможность других исходов ("зависла в воздухе", "встала на ребро"), а также влияние на исход опыта чеканки на сторонах монеты, отклонения формы реальной монеты от правильной и т. д.  чем больше равновозможных событий, тем больше неопределенность ситуации. минимальный размер сообщения о том, что произошло одно из двух равновозможных событий, равен одному биту. информацию о том, что произошло первое событие, можно закодировать в двоичном алфавите нулем, а о том, что произошло второе событие – единицей.  для уменьшения неопределенности в два раза (вместо двух возможных событий – одно реально произошедшее) требуется один бит информации. иначе говоря, сообщение, уменьшающее неопределенность ситуации в два раза, несет один бит информации. если его длина, подсчитанная с использованием алфавитного подхода, больше, значит сообщение несет избыточную, с точки зрения уменьшения неопределенности, информацию.  если информация представлена в виде дискретного сообщения, то логично считать количеством информации его длину, то есть общее число знаков в сообщении. но длина сообщения зависит не только от содержащейся в нем информации. на нее влияет мощность алфавита используемого языка. чем меньше знаков в используемом алфавите, тем длиннее сообщение. так, например, в алфавите азбуки морзе всего три знака (точка, тире, пауза), поэтому для кодирования каждой или латинской буквы нужно использовать несколько знаков, и текст, закодированный по морзе, будет намного длиннее, чем при обычной записи.  пример: сигнал sos: 3 знака в латинском алфавите;   11 знаков в алфавите морзе: ··· пауза – – – пауза ···.  для упорядочивания измерений информационный объем сообщений принято измерять в битах. один бит соответствует одному знаку двоичного алфавита. итак, чтобы измерить длину сообщения, его нужно представить в двоичном виде и подсчитать количество двоичных знаков – битов. при этом совсем не обязательно уметь интерпретировать сообщения.
zolotayaoxana1982
Var        a: array[1..15] of integer;     i,k: integer; begin        writeln('исходный массив');         k: =0;         for i: =1 to 15 do        begin              a[i]: =random(30)+10;             write(a[i]: 3);         end;         writeln;         writeln('числа кратные 3');       for i: =1 to 15 do              if (a[i] mod 3 = 0) then            begin                    write(a[i]: 3);                     inc(k);               end;               writeln;               write('таких чисел - ',k); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Известны , полученные студентами за контрольную работу. вычислить максимальный . написать программу в паскале авс.net
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Volodka
VASILEVNA
Manyaya
Viktoriya405
Monstr13
marinazubcko16729
cristiansirbu9974
Drugov_Vladimirovna
tetralek
fmba18
badalovao256
arnaut-anna
Yurevich-Vladimirovich
ehrik-ch
forwandy42