VSArsentev
?>

Составить программу на ''pascal abc'') дана строка, содержащая текст на языке, и некоторая буква. подсчитать, сколько слов начинается с указанной буквы.

Информатика

Ответы

olgakozelskaa492
Var s: string; i,f,l: integer; a: string; begin readln(s); read(a) ; f: =0; l: =length(s); for i: =l downto 1 do begin if s[i]=' ' then              if s[i+1]='a' then f: =f+1; end;               if s[1]='a' then f: =f+1; writeln(f); end.            
oskon008

ответ:

алгоритм- это конечная совокупность точно заданных правил решения произвольного класса или набор инструкций, описывающих порядок действий исполнителя для решения некоторой . в старой трактовке вместо слова «порядок» использовалось слово «последовательность», но по мере развития параллельности в работе компьютеров слово «последовательность» стали заменять более общим словом «порядок». независимые инструкции могут выполняться в произвольном порядке, параллельно, если это позволяют используемые исполнители.

ранее в языке писали «алгорифм», сейчас такое написание используется редко, но, тем не менее, имеет место исключение (нормальный алгорифм маркова).

часто в качестве исполнителя выступает компьютер, но понятие алгоритма необязательно относится к компьютерным программам, так, например, чётко описанный рецепт приготовления блюда также является алгоритмом, в таком случае исполнителем является человек (а может быть и некоторый механизм, ткацкий станок, и

можно выделить алгоритмы вычислительные (о них в основном идет далее речь), и . вычислительные по сути преобразуют некоторые начальные данные в выходные, реализуя вычисление некоторой функции. семантика алгоритмов существенным образом может отличаться и сводиться к выдаче необходимых воздействий либо в заданные моменты времени, либо в качестве реакции на внешние события (в этом случае, в отличие от вычислительного алгоритма, может оставаться корректным при бесконечном выполнении).

понятие алгоритма относится к первоначальным, основным, базисным понятиям . вычислительные процессы алгоритмического характера (арифметические действия над целыми числами, нахождение наибольшего общего делителя двух чисел и т. д.) известны человечеству с глубокой древности. однако в явном виде понятие алгоритма сформировалось лишь в начале xx века.

Низамов
Вобщем случае, трассировка - один из способов отладки программ врукопашную: состояние программы контролируется на определённом отрезке времени её выполнения путём анализа значений переменных. трассировка в том или ином виде при отладке программ сложнее школьного дз практически неизбежна. в простейшем случае, трассировка - вывод значений переменных на экран (например, в окно консоли) , либо расчёт их на бумажке для каждого шага. в более продвинутом варианте используются точки останова, окно наблюдения, выполнение по шагам и, если есть, контекстный интерпретатор выражений. есть также специальная "трассирующая консоль" - интерфейс вывода информации из программы в отладчик, если таковой присутствует. почти любой современный отладчик показывает состояние програмm при её останове, что делает трассировку процессом легко доступным

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу на ''pascal abc'') дана строка, содержащая текст на языке, и некоторая буква. подсчитать, сколько слов начинается с указанной буквы.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Posadskii-Sergeevna
shpakohat
Владимирович_Роман
ribcage52
malgoblin2663
Pgr100
Дмитрий_Владимирович1162
To activate the "Ctrl" functions, press the . ​
pucha5261
mospaskrasnogorbukh
zodgener
kirill76536
pelagia-kola2658
mariy-y34
almazsit85
Болеславовна
▲