tol1974656
?>

Составьте программу поиска трехзначных чисел которые при делении на 43 в остатке 41 а при делении на 47 в остатке 43

Информатика

Ответы

gk230650
Анет таких чисел! var   i: integer; begin   for i: =1 to 10000 do  // по условиям i: =1 to 999       if (i mod 43 = 41) and (i mod 47 = 43) then           writeln(i); end. результаты вывода: 1030 3051 5072 7093 9114 так что минимальное число, удовлетворяющее требованиям, 1030, но оно не трехзначное вот более продвинутый алгоритм, делающий то же самое: var   n43: integer; begin   n43: =127;   repeat       n43: =n43+43;   until (n43 mod 43 = 41) and (n43 mod 47 = 43); //добавить and (n43< 1000)   writeln(n43) end. результат вывода: 1030
Zheleznyakova
Var a: integer;   flag: boolean; begin   flag: =false;   write('введите число ');   readln(a);   if a mod 2 = 0 then  begin       writeln('число ',a,' делится на 2');       flag: =true;   end;   if a mod 3 = 0 then begin       writeln('число ',a,' делится на 3');       flag: =true;   end;   if a mod 4 = 0 then  begin       writeln('число ',a,' делится на 4');       flag: =true;   end;   if a mod 5 = 0 then  begin       writeln('число ',a,' делится на 5');       flag: =true;   end;   if not flag then writeln('число ',a,' не делится на 2,3,4,5'); end.
asl09777
Var n,m: integer; begin write('n = '); readln(n); write('m = '); readln(m); case n of 6: write('шестерка '); 7: write('семерка '); 8: write('восьмерка '); 9: write('девятка '); 10: write('десятка '); 11: write('валет '); 12: write(' '); 13: write('король '); 14: write('туз '); else writeln('ошибка ввода '); end; case m of 1: write('пик'); 2: write('треф'); 3: write('бубен'); 4: write('червей'); else writeln('ошибка ввода '); end; end. пример: n = 10 m = 2 десятка треф

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу поиска трехзначных чисел которые при делении на 43 в остатке 41 а при делении на 47 в остатке 43
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Sergeevna803
kate281078
karien87
vadimkayunusov
dianakryukova00
Aleksandrovich-Yurevna1421
Viktorovna
Galliardt Sergeevna1284
Виктор Попова
gladkihvv
Anastasiamoscow80
Liliya1106
annakuzina2023
gorsimonyan4
nickcook424
▲