Баранов955
?>

Мне надо подробное решение. на вход программе подается последовательность символов, заканчивающаяся точкой. требуется написать программу, которая определяет, есть ли в этой последовательности десятичные цифры, и выводит наибольшее число, которое можно составить из этих цифр. ведущих нулей в числе быть не должно (за исключением числа 0, запись которого содержит ровно одну цифру если цифр нет, программа должна вывести на экран слово «нет», а если есть – слово «да» и в следующей строчке искомое число. например, если исходная последовательность была такая: day 10, mice 8: "year" 7 is a mistake 91. то результат должен быть следующий: да 987110

Информатика

Ответы

Кирьяков-Крикунов
Var   str, num: string; begin   readln(str); //str : = 'day 10, mice 8: "year" 7 is a mistake 91.';   foreach c: char in str do     if (char.isdigit(c)) then       num += c;   for j: byte : = 1 to length(num) - 2 do     for i: byte : = 1 to length(num) - 1 do       if (num[i] < num[i + 1]) then       begin         str[1] : = num[i];         num[i] : = num[i + 1];         num[i + 1] : = str[1];       end;   if (integer.parse(num) > 0) then   begin     while (num[num.length - 1] = '0') do       num.remove(num.length - 1);     writeln('да' + #13 + num);   end   else     writeln('нет'); end.
drevile57

Объяснение:

Добавление гиперссылки

Объекты можно связывать между собой гиперссылками. При гиперссылок можно открывать файлы, Web-страницы или отдельные страницы блокнота. Для добавления гиперссылки необходимо выполнить следующие действия:

1. Перейти на страницу блокнота, с которой будет осуществляться активирование будущей ссылки.

2. Выделить объект, который необходимо снабдить гиперссылкой.

3. Выполнить команду Вставка ? Гиперссылка.

4. В появившемся окне Гиперссылка указать объект, который должен открываться по гиперссылке.

5. Нажать кнопку Обзор… для установки ссылки на внешний объект или Web-страницу.

6. Щелкнуть по кнопке OK.

Dmitrievich1871

1)В предложении 33 символа. Следовательно, размер предложения в кодировке Unicode составляет: 33 · 16 = 528 бит.

2)Найдем количество символов в статье:

10 · 32 · 48 = 5 · 21 · 25· 3 · 24 = 15 · 210.

Один символ кодируется двумя байтами, 210 байт составляют 1 килобайт, поэтому информационный объем статьи составляет

15 · 211 байт = 15 · 21 килобайт = 30 Кбайт.

3)Общий объём статьи равен x · 64 · 64 · 8 бит = 48 Кбайт.

Следовательно, количество страниц в статье равняется:

x = (48 · 1024 · 8)/(64 · 64 · 8) = 12.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Мне надо подробное решение. на вход программе подается последовательность символов, заканчивающаяся точкой. требуется написать программу, которая определяет, есть ли в этой последовательности десятичные цифры, и выводит наибольшее число, которое можно составить из этих цифр. ведущих нулей в числе быть не должно (за исключением числа 0, запись которого содержит ровно одну цифру если цифр нет, программа должна вывести на экран слово «нет», а если есть – слово «да» и в следующей строчке искомое число. например, если исходная последовательность была такая: day 10, mice 8: "year" 7 is a mistake 91. то результат должен быть следующий: да 987110
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Мунировна
Golubovskayairina
TrubnikovKlimenok926
arhangel1055
lebedev815
АЛЕКСЕЙ
belka1976
Okunev1034
zigrin
kurmaleeva
DmitrievnaVera
egorov
alfaantonk
marketing601
Olga1233