thedoomsdatdcs36
?>

Сделать на pascalabc, попросили сделать с записей. составить программу, которая вводит данные о студентах: № п/п, фамилию, год рождения, пол, курс, вид спорта и выводит: выводит данные только о спортсменках по курсам и спорта в алфавитном порядке.

Информатика

Ответы

ПолухинаТененева565
Const n=3; type student=recordfam: string[20]; year: integer; sex: string[1]; kurs: integer; sport: string[30]; end; var x: array[1..n] of student; i,j: integer; p: student; beginfor i: =1 to n dowith x[i] do beginwriteln('сведенья о ',i,' студенте: '); writeln('фамилия: '); read(fam); writeln('год рождения: '); read(year); writeln('пол( м или ж ): '); read(sex); writeln('курс: '); read(kurs); writeln('вид спорта: '); read(sport); end; for i: =1 to n-1 dofor j: =i+1 to n doif x[i].fam> x[j].fam then beginp: =x[i]; x[i]: =x[j]; x[j]: =p; end; for i: =1 to n do beginwith x[i] doif (sex='ж') then writeln('фамилия студентки:   ',fam,' курс:   ',kurs,' вид спорта:     ',sport); end; end.
Elenazhukovafashion7

Сопоставьте определения в гонке роботов с названием Самый интересный из роботов EV3 Роботы должны удалить соперника с ринга в течение определенного времени, если через определенное время оба робота приблизятся к середине ринга, победителем будет один гонок. Если внутри круга, Робо-сумо соответствует. Внешний диаметр круга отмечен точкой в середине внутреннего диаметра - тип поля, который составляет 100 мм, 1000 мм, красный Схватка между двумя роботами. состоит из нескольких раундов. Робо - C * Y * M * O 2

rusinfopro
// pascalabc.net 3.2, сборка 1399 от 08.03.2017 // внимание! если программа не работает, обновите версию! begin   var a: =arrrandom(100,-1000,1000); a.println;   var imax: =a.indexmax;   var imin: =a.indexmin;   writeln('индекс минимального ',imin+1,', максимального ',imax+1);   if imin> imax then swap(imin,imax);   writeln('сумма на участке: ',a[imin: imax+1].sum) end. пример -65 273 -273 58 108 919 -114 -119 -848 -24 301 -497 348 -386 -235 421 -907 -891 -151 675 -185 89 -991 -276 -802 914 959 -64 848 911 573 -941 59 -522 -460 890 963 840 85 -932 -974 -110 -698 785 537 867 778 -889 239 -659 -972 655 665 -136 555 847 263 -998 -141 194 961 950 34 -758 403 242 444 -130 -927 -124 459 -747 25 -220 649 925 -214 -775 188 -668 -865 847 698 506 882 919 -606 -806 -76 -306 -374 960 -19 891 -892 -923 857 -940 -619 -706 индекс минимального 58, максимального 37 сумма на участке: 1711

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Сделать на pascalabc, попросили сделать с записей. составить программу, которая вводит данные о студентах: № п/п, фамилию, год рождения, пол, курс, вид спорта и выводит: выводит данные только о спортсменках по курсам и спорта в алфавитном порядке.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Maria095096
alfaantonk
olimov9
Nikolaevich1534
Матвеев
oknacrow
ludakamasana
shajmasha
tatiana2676
Ulianev77
bochkarevazh
boldireve617
Irinalobanowa
tatyanaryzhkova
Olga1233