Zeitlinama7067
?>

Написать программу на языке с++ дан массив вещественных чисел.среди них есть равные.найти его первый максимальный элемент и заменить его нулем.

Информатика

Ответы

Dms161964937
Var a,b,c: real; begin write('введите 3 числа: '); readln (a,b,c); if c = sqrt(a*a + b*b) then writeln('число ',c,' является гипотенузой прямоугольного треугольника со сторонами ',a,' ',b,' ',c) else if a = sqrt(c*c + b*b) then writeln('число ',a,' является гипотенузой прямоугольного треугольника со сторонами ',a,' ',b,' ',c) else if b = sqrt(a*a + c*c) then writeln('число ',b,' является гипотенузой прямоугольного треугольника со сторонами ',a,' ',b,' ',c) else writeln('эти числа не являются сторонами прямоугольного треугольника') end.
girra
#include < iostream> int main(void) {     int cur, prev, next, ans;     prev = ans = 0;     std: : cin > > next;     while (true) {         cur = next;         if (cur == 0) {             break;         }         std: : cin > > next;         if ((prev == 0 || cur > prev) & & (next == 0 || cur > next)) {             ans++;         }           prev = cur;     }     std: : cout < < ans < < std: : endl;     return 0; }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке с++ дан массив вещественных чисел.среди них есть равные.найти его первый максимальный элемент и заменить его нулем.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Vitalevich
Yulechkaakulova1993
msburmis
dimkimka386
Nazaruk_Kodochigov
Amelin-Alipova
Karlova1507
eobmankina
PetrovDrozdov1785
kononova_Pavel689
melissa-80
Tatyana_Minullina
sawa-msk
margarita25061961
teta63
▲