sevro3038
?>

Решите-дано 3-х значное целое число, написать программу вычисления суммы его чисел

Информатика

Ответы

alexseyzyablov
Прикрепил файл с программой 
Агибалов428

ответ:

объяснение: 1.компьютер-не обязательно мощный, с любой операционной системой.

2.интернет.в последнее время цены на пользование интернетом значительно снизились, а качество и скорость улучшились. так как придется посещать множество сайтов ,то лучше подключить бeзлимитный тариф.

3.антивирус-без него никак! нужно устанавливать один антивирус на компьютер. два установленных антивируса могут конфликтовать между собой , вызывая проблемы в работе системы. проводится много дискуссий по поводу лучшего антивируса и однозначного ответа пока нет .к примеру nod32 не плохо справляется со своей :

shoko-2379

var G,F:file of integer;

   i,j,n:integer;

   s:integer;

   c,c1,c2:integer;

begin

writeln;

write('Vvedite n:');

readln(n);

Assign(G,'C:\g.txt');

Assign(F,'C:\f.txt');

Rewrite(F);

for i:=1 to n do

begin

c1:=1;

c2:=1;

for j:=1 to i+1 do begin

if j<i+1 then c1:=c1*2;

c2:=c2*3;

end;

c:=c1+c2;

write(F,c);

end;

Close(F);

Reset(F);

Rewrite(G);

s:=0;

while not Eof(f) do

begin

read(F,c);

if c>0 then c:=c*(-1);

write(G,c);

s:=s+c;

end;

write(G,s);

close(F);

close(G);

reset(G);

writeln('Komponenty fajla j:');

while not Eof(G) do

begin

read(G,c);

write(c);

end;

readln;

end.

Приклад.Виведення таблиці значень функції у файл.

Програма:

program file_of_values;

var

х : Real;

k : Word;

out_file : Text; {тип Text відповідає файлу. що складається із рядків тексту}

function F(x: Real): Real;  

begin

F := x/d.O + x);  

end;

begin

Assign(out_file, 'c:\user\ivanov\table.dat');

Rewrite(out_file);

x := 0.0;

WriteLn(out_file, 'Таблиця значень функції F(x) = x/(l + x)');

WriteLn(out_file);

WriteLn(out_file, 'x':9, 'F(x)':19);

WriteLn(out_file);

for k := 0 to 50 do  

begin

WriteLn(out_file, x:9:3, F(x):19:9);

x := x + 0.1:

if k mod 10 = 9 then WriteLn(out_file);  

end;

Close(out_file);  

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решите-дано 3-х значное целое число, написать программу вычисления суммы его чисел
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

grafffmc
stalker2201
Wlad967857
Yurevna991
Новицкий1107
uksusoval617
webotryvclub21
teashop
info292
Сергеевна
Николаевич1033
Олегович Паутова
mixtabak2
Андреевна
fedotochkin8
▲