Шиморянов Мария1866
?>

Решение в среде паскаль: написать программу для вычисления кол-ва детей в классе, если изветсно девочек 15, а мальчикво на в человек больше.

Информатика

Ответы

tshelokova

program kids;

var m,j,summa: integer;

begin

  writeln('на сколько мальчиков больше ? '); readln(m);

  j: =15;

  summa: =j+(m+j);

  writeln('в нашем классе ',summa,' человек.');

  readln;

end.

 

j - это сумма девочек, а m+j - это сумма мальчиков.

 

taanaami75

program klass;

uses crt;

var b, s, a: integer;

begin

writeln('введите число, на сколько мальчиков больше чем девочек: b = ');

readln(b);

a: =15+b;

s: =15+a;

writeln('в классе учится ',s,' человек');

readln;

end.

muzeynizhn

1) 12111

2) 21212

3) 21211

Объяснение:

1)

Команда 1: Прибавь 3

Команда 2: Возведи в квадрат

Нужно из 4 получить 58

1) 4 + 3 = 7 [Команда 1]

2) 7² = 49 [Команда 2]

3) 49 + 3 = 52 [Команда 1]

4) 52 + 3 = 55 [Команда 1]

5) 55 + 3 = 58 [Команда 1]

2)

Команда 1: Вычти 1

Команда 2: Возведи в квадрат

Нужно из 2 получить 64

1) 2² = 4 [Команда 2]

2) 4 - 1 = 3 [Команда 1]

3) 3² = 9 [Команда 2]

4) 9 - 1 = 8 [Команда 1]

5) 8² = 64 [Команда 2]

3)

Команда 1: Раздели на 2

Команда 2: Вычти 1

Нужно из 27 получить 3

1) 27 - 1 = 26 [Команда 2]

2) 26 ÷ 2 = 13 [Команда 1]

3) 13 - 1 = 12 [Команда 2]

4) 12 ÷ 2 = 6 [Команда 1]

5) 6 ÷ 2 = 3 [Команда 1]

borisova-Sergeevna

predicates

nondeterm решение(string)

nondeterm условие(integer,integer,integer,integer)

nondeterm имя(integer,integer,integer,integer,integer,string)

clauses

решение(Имя):-

   имя(Таня,Лена,Аня,Катя,Марина,Имя),

   условие(1,Таня,Лена,Аня),

   условие(2,Лена,Аня,Катя),

   условие(3,Аня,Катя,Марина),

   условие(4,Катя,Таня,Марина).

условие(1,Таня,Лена,Аня):-

   Таня=1,Лена+Аня>0;Таня=0.

условие(2,Лена,Аня,Катя):-

   Лена=1,Аня=1,Катя=1;Лена=0.

условие(3,Аня,Катя,Марина):-

   Аня+Катя>0,Марина=0;Аня+Катя=0.

условие(4,Катя,Таня,Марина):-

   Катя=0,Таня=1,Марина=1;Катя=1.

имя(1,0,0,0,0,"Таня").

имя(0,1,0,0,0,"Лена").

имя(0,0,1,0,0,"Аня").

имя(0,0,0,1,0,"Катя").

имя(0,0,0,0,1,"Марина").

goal

решение(Имя).

Объяснение:

Имя=Катя

1 Solution

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решение в среде паскаль: написать программу для вычисления кол-ва детей в классе, если изветсно девочек 15, а мальчикво на в человек больше.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ASRodichev
annademidova-74
marinakmaa86
anovikovsr
ann-perminova2008
vettime625
Aleksei1463
Blekjek730
Voronin-Albertovich
Yevgenevna
yurievaalxndra55
Андрееевич787
Liliya-buc
reception
ecocheminnov437