cmdkotelniki
?>

Сделайте блок-схему и напишите программу для данной : ввести с клавиатуры массив из 5 элементов, найти минимальный из них.

Информатика

Ответы

sergeylive
1) program pr; uses crt; var a,k,k1: integer; beginwriteln('введите a'); readln(a); k1: =1; k: =0; while (a< > 0) and (k1< 1000) dobeginif (a< 0) and (a mod 2=0) and (abs(a)< =30000) then k: =k+1; k1: =k1+1; readln(a); end; writeln('k=',k); readln; end.  2)program pr; uses crt; var a,k,k1: integer; beginwriteln('введите a'); readln(a); k1: =1; k: =0; while (a< > 0) and (k1< 1000) dobeginif (a> 0) and (a mod 2< > 0) and (abs(a)< =30000) then k: =k+1; k1: =k1+1; readln(a); end; writeln('k=',k); readln; end.
Svetlana1335
Const   n = 10; var   x, i, minus, plus: integer; begin   plus: =-1;   minus: =0;   for i: =1 to n do   begin     readln(x);     if x< 0 then       minus: =minus+x;     if x> 0 then       if plus = -1 then                 plus: =x       else           plus: =plus*x;   end;   writeln('сумма отрицательных чисел:   ', minus);   if plus = -1 then     writeln('положительных чисел нет')   else     writeln('произведение положительных чисел: ', plus); end. 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Сделайте блок-схему и напишите программу для данной : ввести с клавиатуры массив из 5 элементов, найти минимальный из них.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kalina1372
iservice38
toxicfish
fta1309
punctvydachi
vallod
Borshchev1820
serg1976g
Щербаков33
Гарик383
Verakravez8790
serg1976g
Maksim Lokhov
oniks-plus
Volochaev