antongenfon
?>

Выполнить в paskal n=12 ввести число к определить количество элементов массива, значения которых больше k. все элементы массива увеличить в 3 раза. массив вывести. определить максимальное значение сред положительных элементов массива.

Информатика

Ответы

Геннадьевна_Петр
Const   n = 12; var   a: array[1..n] of integer;   i, k, p, max: integer; begin   randomize;   write('введите число к: ');   readln(k);   write('элементы массива: ');   p : = 0;   for i : = 1 to n do   begin       a[i] : = random(101)-50;       write(a[i]: 5);       if a[i] > k then p : = p + 1;   end;   writeln(#13#10, 'количество элементов, больших ', k, '=', p);   max : = -32768;   for i : = 1 to n do   begin       a[i] : = 3 * a[i];       if max < a[i] then max : = a[i]   end;   if max > 0 then writeln('максимальный элемент массива равен ', max)   else writeln('в массиве нет положительных элементов') end. тестовое решение: введите число к: 25 элементы массива:     -10    43    -6      8    -4    39    26  -30  -33  -10  -34    -4 количество элементов, больших 25=3 максимальный элемент массива равен 129
krylova-natali

На C++:

#include <iostream>

#include <cmath>

using namespace std;

int main() {

setlocale(0, "RU");

int a, b, c;

cout << "Введите коэффициенты уравнения: ";

cin >> a >> b >> c;

cout << "D = b^2 - 4 * a * c\n";

cout << "D = " << b * b << " - " << 4 * a * c << endl;

double D = (b * b) - (4 * a * c);

cout << "D = " << D << endl;

int d = sqrt(D);

cout << "vD = " << endl << endl;

 

 

a *= 2;

int x1 = (-b - d) / a;

int x2 = (-b + d) / a;

cout << "x1 = (-b - vD) / 2a = " << x1 << endl;

cout << "x2 = (-b + vD) / 2a = " << x2;

return 0;

}

ALLA1868

На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом.

1. Строится двоичная запись числа N.

2. К этой записи дописываются справа ещё два разряда по следующему правилу:

а) складываются все цифры двоичной записи, и остаток от деления суммы на 2 дописывается в конец числа (справа). Например, запись 11100 преобразуется в запись 111001;

б) над этой записью производятся те же действия – справа дописывается остаток от деления суммы цифр на 2.

Полученная таким образом запись (в ней на два разряда больше, чем в записи исходного числа N) является двоичной записью искомого числа R.

Укажите такое наименьшее число N, для которого результат работы алгоритма больше 125. В ответе это число запишите в десятичной системе счисления.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Выполнить в paskal n=12 ввести число к определить количество элементов массива, значения которых больше k. все элементы массива увеличить в 3 раза. массив вывести. определить максимальное значение сред положительных элементов массива.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

amaraks67
grishin
Bni1504
angelina-uj1350
Nikolaevna Malika1511
akremlev2015
Abdullaev
nikolavlad
dariamay1996
md-masya
Vitalevna1186
margo55577869
erere4443
ekaizer
Даниил247