simplexsol
?>

Составить программу которая вводит с клавиатуры целое число, которое уменьшает его в 2 раза и результат выводит на экран.

Информатика

Ответы

dobrovolsky-tmz1
Var x: real; begin readln(x); writeln(x/2) end. (минимализм,  но  программа  рабочая)
Veselova
Вот держи : program hello;   var a : integer; begin              writeln('введите любое число : ');           readln(a);           writeln(a , ' : 2 = ' , a/2); end.
avetisov-84850
// pascalabc.net 3.1, сборка 1219 от 16.04.2016 function isautomorph(s: string): boolean; // возвращает true, если строка s изображает // автоморфное число, иначе возвращает false begin   var b: biginteger;   if biginteger.tryparse(s,b) then       result: =sqr(b).tostring.right(s.length)=s   else result: =false end; begin   var s: =readlnstring('введите натуральное число: ');   if isautomorph(s) then println('автоморфное')   else println('не автоморфное') end. тестовые решения: введите натуральное число: 12890625 автоморфное введите натуральное число: 3245 не автоморфное
expo3217
// pascalabc.net 3.1, сборка 1219 от 16.04.2016 function sod(n: int64): integer; begin   result: =0;   while n> 0 do begin       result+=n mod 10;       n: =n div 10       end end;       begin   var a: =readarrinteger('введите три натуральных числа: ',3);   write('суммы цифр чисел: '); a.select(x-> sod(;   writeln('общая сумма цифр всех чисел: ',a.select(x-> sod() end. тестовое решение: введите три натуральных числа: 56325 23131 784545223 суммы цифр чисел: 21 10 40 общая сумма цифр всех чисел: 71

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу которая вводит с клавиатуры целое число, которое уменьшает его в 2 раза и результат выводит на экран.
Ваше имя (никнейм)*
Email*
Комментарий*