Надья-Олеговна
?>

Составить программу на языке ! числа люка определяются так: первое число равно 1, второе равно 3, каждое следующее равно сумме двух предыдущих. составить программу, которая находит сумму первых k чисел люка (k – задается пользователем определить количество первых чисел люка, таких, что значение ихсуммы не превышает диапазона типа int (long int). вывести в виде таблицы данное значение суммы и три предыдущих значения суммы (с соответствующими количествами чисел люка).

Информатика

Ответы

eobmankina
Переделал ваш код с паскаля #include < iostream> using namespace std; int main() { long int f[100]; long int k, i, s; cin> > (k); f[1] = 1; f[2] = 3; if (k > 0) s = 1; if (k > 1) s = 4; for (int i = 3; i< =k; i++) { f[i] = f[i - 1] + f[i - 2]; s = f[i] + s; } cout< < s; return 0;
de1979nis

ЯП: С++

#include <iostream>

int main() {

const int N = 5;

int arr[N][N] = {1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25}; // создаем и заполняем двумерный массив 5x5

for (int i = 0; i < N; i++) // выводим на экран 2-мерный массив;

{

 for (int j = 0; j < N; j++)

 {

  std::cout << arr[i][j] << "\t";

 }

 std::cout << std::endl;

}

std::cout << "Result #1: ";

for (int i = 0; i < N; i++) // вывод в консоль главной диагонали

{

 std::cout << arr[i][i] << "\t";

}

std::cout << "\nResult #2: ";

for (int i = 0; i < N; i++) // вывод в консоль побочной диагонали

{

 std::cout << arr[i][N - 1 - i] << "\t";

}

return 0;

}

Объяснение:

potemkin77
Во-первых, не "10 ричная" система счисления, а десятичная. а во-вторых, надо составить уравнение, используя расширенное представление числа в системе счисления по основанию n. из условия следует, что n> 4 (цифра 4 не может присутствовать в записи числа по основанию меньше 5) и n< 10 (в десятичной системе счисления число двухзначное, а три знака возможны только в системе счисления с меньшим основанием). относительно a и b можно утверждать, что оба они целые, a ∈ [1; 9], b∈ [0; 9] при этих ограничениях получается, что число 30 должно быть кратно n, следовательно n=5. можно также найти a и b, несмотря на то, что по условию этого не требуется. b=6-5a и это возмжно только при a=1. тогда b=6-5=1. искомое число - 114 в пятиричной системе счисления. ответ: n=5

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу на языке ! числа люка определяются так: первое число равно 1, второе равно 3, каждое следующее равно сумме двух предыдущих. составить программу, которая находит сумму первых k чисел люка (k – задается пользователем определить количество первых чисел люка, таких, что значение ихсуммы не превышает диапазона типа int (long int). вывести в виде таблицы данное значение суммы и три предыдущих значения суммы (с соответствующими количествами чисел люка).
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

eidevyatkina
Dmitriy2211104
alfastore4
baeva-larisa8165
arturusinsk5
egoryandiana3727283
Александра Викторович531
Исаченко Тераски1181
alenih13
Aleksandrovich_Mitoyan1138
Gesper63
yliana
Максим_Нина
artashhovhan
oalexandrova75