Ivanovich-A.V
?>

Составить программу в paskal abc лицензионный сбор взимается в следующих размерах к минимальной месячной оплате труда в зависимости от действия лицензии: до 1 года – 30%, от 1 до 2 лет – 40%, от 2 до 3 – 50%, от 3 до 4 лет – 60%, от 4 до 5 – 70%. в случае утери лицензии сбор 20% от первоначального сбора. составьте программу определения лицензионного сбора.

Информатика

Ответы

mashuska
Var   z, s: real;   n, p: integer; begin   write('введите размер оплаты труда: ');   readln(z);   write('лицензия первичная (1) или повторная (2)? ');   readln(p);   writeln('на сколько лет выдается лицензия? ');   writeln('0 - до года, 1 - 1-2 года, 2 - 2-3 года,');   write('3 - 3-4 года, 4 - 4-5 лет: ');   readln(n);   case n of       0: s : = 0.3 * z;       1: s : = 0.4 * z;       2: s : = 0.5 * z;       3: s : = 0.6 * z;       4: s : = 0.7 * z;   else s : = 1e9   end;   if p = 2 then s : = 0.2 * s;   writeln('сумма лицензионного сбора составит ', s: 0: 2) end. тестовое решение: введите размер оплаты труда: 26400 лицензия первичная (1) или повторная (2)? 1 на сколько лет выдается лицензия? 0 - до года, 1 - 1-2 года, 2 - 2-3 года, 3 - 3-4 года, 4 - 4-5 лет: 2 сумма лицензионного сбора составит 13200.00
mmreznichenko
Uses  graphabc;   begin  setpencolor(clgreen);   line(100,100,120,140);   line(100,100,80,140);   line(80,140,120,140);   line(100,140,70,190);   line(100,140,130,190);   line(70,190,130,190);   line(100,190,50,250);   line(100,190,150,250);   line(50,250,150,250);   floodfill(100,160,clgreen);   floodfill(100,130,clgreen);   floodfill(100,200,clgreen);   line(300,100,320,140);   line(300,100,280,140);   line(280,140,320,140);   line(300,140,270,190);   line(300,140,330,190);   line(270,190,330,190);   line(300,190,250,250);   line(300,190,350,250);   line(250,250,350,250);   floodfill(300,160,clgreen);   floodfill(300,130,clgreen);   floodfill(300,200,clgreen);   line(500,100,520,140);   line(500,100,480,140);   line(480,140,520,140);   line(500,140,470,190);   line(500,140,530,190);   line(470,190,530,190);   line(500,190,450,250);   line(500,190,550,250);   line(450,250,550,250);   floodfill(500,160,clgreen);   floodfill(500,130,clgreen);   floodfill(500,200,clgreen);   end.
ainetdinovsnab
// pascalabc.net 3.3 const n=4; begin   writeln('1 массив: ');   var a: =matrrandom(n,n,-10,10); a.println(6);   writeln('2 массив: ');   var b: =matrrandom(n,n,-10,10); b.println(6);   var c: =a.elementsbyrow.where(x-> x< 0)+b.elementsbyrow.where(x-> x< 0)+       a.elementsbyrow.where(x-> x=0)+b.elementsbyrow.where(x-> x=0)+       a.elementsbyrow.where(x-> x> 0)+b.elementsbyrow.where(x-> x> 0);   c.println; end. пример: 1 массив:     -6    -3      1      8       6    -3    -8      0       8    10    -3    -9       1    -9    -2      6 2 массив:     -7    -1    -3      9     -2    -6      5      2       0    10      1      0       5    -2      5      5 -6 -3 -3 -8 -3 -9 -9 -2 -7 -1 -3 -2 -6 -2 0 0 0 1 8 6 8 10 1 6 9 5 2 10 1 5 5 5

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу в paskal abc лицензионный сбор взимается в следующих размерах к минимальной месячной оплате труда в зависимости от действия лицензии: до 1 года – 30%, от 1 до 2 лет – 40%, от 2 до 3 – 50%, от 3 до 4 лет – 60%, от 4 до 5 – 70%. в случае утери лицензии сбор 20% от первоначального сбора. составьте программу определения лицензионного сбора.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

restkof
Nataliyaof
galereyaas1568
gk230650
Zhanibekrva Kandaurova
ustinovda14
pokrov777krest
zabrodin
Igor120
LYuBOV
cleopatra1959
Илья_Ветклиники1655
schernov
qcrv15312
det-skazka55
▲