tarasovs
?>

Требуется написать программу, вычисляющую значение какой-нибудь функции(y=f( такой: y=x-2 если х больше 0 y=0 если х = 0 y=модулю х если х меньше 0

Информатика

Ответы

Dmitrievna Lvovich

#include <iostream>

#include <vector>

#include <algorithm>

using namespace std;

void solve(){

   int n, sum = 0;

   bool ok = false;

   cin >> n;

   vector<int> a(n);

   for(auto &i: a) { cin >> i; sum += i;}

   sort(a.begin(), a.end());

   for(int i = 0; i < n; i++){

       int l = i + 1, r = n - 1;

       while(l <= r && !ok){

           int m = (l + r) / 2;

           if(a[m] < sum - a[i])

               l = m + 1;

           else if(a[m] > sum - a[i])

               r = m - 1;

           else

               ok = true;

       }

   }

   cout << (ok ? "YES" : "NO");

}

int main(){

   solve();

}

Immortal3331
1) б и с 2) read(a) ввод в переменную с клавиатуры. a: =значение просто присваивание  3)  program a1;   var a, b, c: integer;   begin  writeln('введите значения переменных a и b');   read(a, b);   writeln((a+b+c)/3);   end.  название программы и переменной были одинаковые. так нельзя. переименовал программу4) б)program znanija;   var a, b, h: integer;   begin  writeln('введите a, b и h');   read(a, b, h);   writeln('площадь трапеции ',(a+b)/2*h);   end.  5)program znanija;   var a, b, i: integer;   begin  read(a); for i: =1 to a do  begin    b: =b + a mod 10;     a: =a div 10;   end;     writeln(b); end.  работает не только для трёхзначных. но и двух, трёх, четырёх и т.д.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Требуется написать программу, вычисляющую значение какой-нибудь функции(y=f( такой: y=x-2 если х больше 0 y=0 если х = 0 y=модулю х если х меньше 0
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

alazaref
abdulhakovalily22
olyavoznyak
infooem
Vikkitrip
yaart-klementiev29
сузанна_Людмила
necit12
mila-vsv
klimenko05
Прошкин_Николай368
moidela87
Иванович
beliaeva2
Radikovnanikolaeva