Kulikovvl9
?>

Напишите программу в паскале абс. с клавиатуры вводятся целые числа a, b и c. вычислите значение следующего выражения где max(a, b, c) — выбирает максимальное значение из трех чисел, а min(a, b, c) — минимальное значение из трех чисел. подумайте, как в данной программе использовать функции нахождения максимального или минимального из двух чисел.

Информатика

Ответы

parolmm
A,b,c: real напиши саму я тебе её решу
apro3444595

begin

  var (cost, t, k) : = (arr(15, 70, 125, 230, 440), arr(1, 5, 10, 20, 60), new integer[5]);

  var n : = readinteger('n-> ');

  for var i : = 4 downto 0 do

  begin

    k[i] : = n div t[i]; n : = n mod t[i];

  end;  

  if k[0] * cost[0] > = cost[1] then begin k[0] : = 0; inc(k[1]); end;

  if k[0] * cost[0] + k[1] * cost[1] > = cost[2] then 

  begin

    k[0] : = 0; k[1] : = 0; inc(k[2]);  

  end;

  if k[0] * cost[0] + k[1] * cost[1] + k[2] * cost[2] > = cost[3] then 

  begin

    k[0] : = 0; k[1] : = 0; k[2] : = 0; inc(k[3]);

  end;

  if k[0] * cost[0] + k[1] * cost[1] + k[2] * cost[2] + k[3] * cost[3] > = cost[4] then 

  begin

    k[0] : = 0; k[1] : = 0; k[2] : = 0; k[3] : = 0; inc(k[4]);  

  end;

   

  for var i : = 0 to 4 do writelnformat('{0} билет(ов)- {1} штук(а)', t[i], k[i]);

end.

пример(1):

n-> 37

1 билет(ов)- 0 штук(а)

5 билет(ов)- 0 штук(а)

10 билет(ов)- 0 штук(а)

20 билет(ов)- 0 штук(а)

60 билет(ов)- 1 штук(а)

пример(2):

n-> 35

1 билет(ов)- 0 штук(а)

5 билет(ов)- 1 штук(а)

10 билет(ов)- 1 штук(а)

20 билет(ов)- 1 штук(а)

60 билет(ов)- 0 штук(а)

ilyagenius
Как и сказал, смог только первый. для начала нужно ввести числа квадратного уравнения в строку. то есть, числа вместо a, b и c. а потом надо ввести в строку число "х", чтобы проверить его на наличие решения. вот сам код: program name; var a, b, c, d, x1, x2, x3: real; begin writeln('введите коэффициенты квадратного уравнения') ; readln(a, b, c); d: =sqr(b) - (4*a*c); x1: = (-b-sqrt(d)) / 2*a; x2: = (-b+sqrt(d)) / 2*a; writeln('введите число х, чтобы проверить, является ли оно корнем уравнения') ; readln(x3); if x3 = x1 then writeln('число ', x3, ' является корнем уравнения.') else if x3 = x2 then writeln('число ', x3, ' является корнем уравнения.') else writeln('число ', x3, ' не является корнем уравнения.') ; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу в паскале абс. с клавиатуры вводятся целые числа a, b и c. вычислите значение следующего выражения где max(a, b, c) — выбирает максимальное значение из трех чисел, а min(a, b, c) — минимальное значение из трех чисел. подумайте, как в данной программе использовать функции нахождения максимального или минимального из двух чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Исмагилова_Саният
anastasiaevent4
Mbkozlov6
Evsevia-a
artem
manager-3
ribcage52
des-32463
GALINAMTO
vasiliiparshin7668
apro3444595
ashantik
miumiumeaow
a1rwalk3r
smakejkina
▲