ukkavtodor6
?>

Написать на языке си программу, которая выводит n введенных чисел в порядке возрастания, используя массивы и сортировку.

Информатика

Ответы

Pastushenkoen
#include < iostream> using namespace std; void main() {   int k,n;   int mas[999];   cin> > n;   for(int i=0; i< n; i++)     cin> > mas[i];   for(int i=0; i< n-1; i++)     for(int j=0; j< n-i; j++)       if(mas[j]> mas[j+1])       {         k=mas[j];         mas[j]=mas[j+1];         mas[j+1]=k;       }   for(int i=0; i< n; i++)     cout< < mas[i]< < "  ";   system("pause"); }
galkavik

ответ

4,0/5

2

SilverWind

   середнячок

   8 ответов

   2.6 тыс. пользователей, получивших

1. вывести на экран 6 раз своё имя

program imya;

const n=6;

var i:integer;

begin

for i:=1 to n do

writeln('ваше имя');

end.

Пояснения: делала с цикла (можно было написать и шесть раз writeln, но так удобнее). Переменную n ввела для быстрого изменения значений (если нужно будет написать имя не 6, а, к примеру, 8 раз, нужно было заменить только вначале). Ещё хочу отметить, что имя вводится по-английски и нельзя терять апострофы ( ' ).

2. program sum;

var sum:integer;

m:array[1..4] of integer;

i:integer;

begin

m[1]:=6

for i:=2 to 4 do begin

m[i]:=m[i-1]+1;

end;

sum:=m[1];

for i:=2 to 4 do begin

sum:=sum+m[i];

end;

writeln(sum);

end.

Пояснения: можно было делать и по-другому, но так тоже верно. Тут использовалось два цикла и массив. А блок-схему сами сделайте)))

3. program n!;

var n:real;

c:integer;

m:array[1..n] of integer;

begin

readln(n)

m[1]:=1;

for i:=2 to n do begin

m[i]:=m[i-1]+1;

end;

c:=m[1]

for i:=1 to n do begin

c:=c*m[i];

end;

writeln('n!',c);

end.

Если что не понятно, пишите, объясню

Объяснение:

сосиска

potemkin77

Написать программу, которая будет показывать на экран квадрат числа, введенного пользователем. Пользователь должен сам решать – выйти из программы или продолжить ввод. (Подсказка – необходимо запустить бесконечный цикл, в котором предусмотреть его прерывание, при наступлении определённого условия).

Показать код

2. В спортзал ежедневно приходит какое-то количество посетителей. Необходимо предложить пользователю ввести такие данные: сколько человек посетило спортзал за день, ввести возраст каждого посетителя и в итоге показать возраст самого старшего и самого молодого из них, а так же посчитать средний возраст посетителей.

Показать код

Для самостоятельно задания, предлагаем вам решить похожую задачу. Организовать ввод количества посетителей спортзала и количества часов проведенных каждым из них в спортзале. В итоге посчитать и показать общую сумму, которую посетители заплатили за тренировки.

3. На складе имеется определённое количество ящиков с яблоками (в нашем примере 15). Когда подъезжает машина для погрузки, попросить пользователя ввести, сколько ящиков загрузить в первую машину, во вторую и так далее, пока не закончатся ящики с яблоками. Предусмотреть тот случай, когда пользователь введёт количество ящиков больше, чем есть на складання

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать на языке си программу, которая выводит n введенных чисел в порядке возрастания, используя массивы и сортировку.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Vyacheslavovna1867
shuttse
elenaneretina
kayrina
koxhulya61
Геннадьевич-Тимофеева158
nelli-bi6
ekater01806
dobrovolsky-tmz1
ren7869
samoilovcoc
marusyamr
OlgaVasilevna
Беспалова
kuharchuks