edubenskaya
?>

Дано натуральное число. найти число, получаемое из исходного перестановкой его первой и последней цифр.написать программу в среде devc++ или c++, люди.

Информатика

Ответы

fedchenkoofficial
Данная достаточно легко реализуется с строкового типа. #include < iostream> #include < string.h> int main() {     char number[1000];   std: : cin > > number;     int first = number[0]; int second = number[strlen(number)-1];     number[0]=second; number[strlen(number)-1]=first;     std: : cout < < number;     return 0; }
Vasilii1891
// pascalabc.net 3.1, сборка 1230 от 27.04.2016 procedure matprint(a: array[,] of integer); begin   var maxcol: =length(a,1)-1;   for var i: =0 to length(a,0)-1 do begin       for var j: =0 to maxcol do print(a[i,j]);       writeln       end end; begin   var m: =readinteger('кол-во строк: ');   var n: =readinteger('кол-во столбцов: ');   var t: =matrixrandom(m,n,10,99); // инициализация матрицы   matprint(t);   var a: =new real[n]; // массив для средних по столбцам   for var j: =0 to n-1 do begin       var s: =0;       for var i: =0 to m-1 do s+=t[i,j];       a[j]: =s/m       end;   // cортированная последовательность индексов столбцов   var ai: =a.select((x,i)-> rec(x,       .select(x-> x.item2).toarray;   // cоздаем промежуточный массив   var u: array[,] of integer; setlength(u,m,n);   for var j: =0 to n-1 do       for var i: =0 to m-1 do u[i,j]: =t[i,ai[j]];   t: =copy(u); // вернем назад данные в исходный массив   writeln;   matprint(t); end. тестовое решение кол-во строк: 5 кол-во столбцов: 8 24 30 70 85 92 32 11 25 83 92 64 51 28 47 10 22 50 14 76 84 23 63 64 39 30 22 84 59 55 32 58 63 80 36 53 74 80 82 84 33 85 70 92 24 32 11 30 25 51 64 28 83 47 10 92 22 84 76 23 50 63 64 14 39 59 84 55 30 32 58 22 63 74 53 80 80 82 84 36 33
Shishkinaanasta1997
// pascalabc.net 3.1, сборка 1230 от 27.04.2016 begin   var a: =readalllines('in.txt')[0].tointegers;   writeln('исходный набор отметок'); a.println;   var k3: =a.where(x-> x=3).count;   var k4: =a.where(x-> x=4).count;   var k5: =a.where(x-> x=5).count;   writeln('троек- ',k3,', четверок- ',k4,', пятерок-',k5) end. тестовое решение исходный набор отметок 3 4 4 5 5 3 4 4 5 4 3 5 5 3 5 3 4 3 3 4 5 4 4 3 4 4 3 4 5 4 троек- 9, четверок- 13, пятерок-8 файл с отметками in.txt дан во вложении.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано натуральное число. найти число, получаемое из исходного перестановкой его первой и последней цифр.написать программу в среде devc++ или c++, люди.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Burov1446
info2
Astrians
VladimirBorisovich
Газинурович
Alesander-Isaev684
familumid
vettime625
selena77
alexfold
thebest59
Семеновна-Павел
alplakhota67
d43irina
iuv61
▲