iuv61
?>

Составить программы для задач (в Паскале) 1) Вводится натуральное число N. Вывести все целые числа от N до 1. Пример: Входные данные: 5 Выходные данные: 5 4 3 2 1 2) Вводятся два целых числа A и B. Вывести все нечётные числа от A до B, включая A и B. Пример: Входные данные: 3 10 Выходные данные: 3 5 7 9 3) Вводятся два целых числа A и B. Вывести сумму всех чисел от A до B, включая A и B, которые заканчиваются на 7. Пример: Входные данные: 5 30 Выходные данные: 51 (Пояснение: 7+17+27=51) Хелп ми

Информатика

Ответы

zrs-546

я не думаю что это так но я это понимаю вот так -                                            


Составить программы для задач (в Паскале) 1) Вводится натуральное число N. Вывести все целые числа о
Columbia777
1. Для цикла For

var
  x,n,p:longint;
  i:integer;
begin
  readln (x,n);
  p:=1;
  for i := 1 to N do
    p:=p*x;
  writeln(x,' в степени ',n,' равно ',p );
end.

2. Для цикла While
var
  x,n,p:longint;
  i:integer;
begin
  readln (x,n);
  p:=1;
  i:=1;
  while i<=n do begin
    p:=p*x;
    i:=i+1;
  end;
  writeln(x,' в степени ',n,' равно ',p );
end.

3. Для цикла Repeat

var
  x,n,p:longint;
  i:integer;
begin
  readln (x,n);
  p:=1;
  i:=1;
  repeat
    p:=p*x;
    i:=i+1;
  until i>n;
  writeln(x,' в степени ',n,' равно ',p );
end.
krimenu5033

program sravnenie;

var a,b:integer;

begin

 write('Введите первое число для сравнения: ');

 readln(a);

 write('Введите второе число для сравнения: ');

 readln(b);

 if(a>b) then writeln('Первое число ',a, ' больше второго числа ',b)

 else if(a=b) then writeln('Первое число ',a, ' равно второму числу ',b)

 else writeln('Первое число ',a, ' меньше второго числа ',b);

end.

Объяснение:

Выше программа на языке программирования Pascal

Если будет нужно на Python/C++, напишешь в комментарии, добавлю

Надеюсь , удачи.

К ответу прикрепляю скриншот, что всё работает


Напишите код программы на сравнение 2-х чисел ​

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программы для задач (в Паскале) 1) Вводится натуральное число N. Вывести все целые числа от N до 1. Пример: Входные данные: 5 Выходные данные: 5 4 3 2 1 2) Вводятся два целых числа A и B. Вывести все нечётные числа от A до B, включая A и B. Пример: Входные данные: 3 10 Выходные данные: 3 5 7 9 3) Вводятся два целых числа A и B. Вывести сумму всех чисел от A до B, включая A и B, которые заканчиваются на 7. Пример: Входные данные: 5 30 Выходные данные: 51 (Пояснение: 7+17+27=51) Хелп ми
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

shilinmikhaillg
Mbkozlov6
anovikovsr
Сергеевич1386
Liliya-buc
tigran87-87
vettime625
imosal
gusrva3001
betepah
Sergei1805
Yevgenevna
reception
ekasatkina
Aleksei1463