e9rebrova
?>

Составить блок схему и написать программу на языке паскаль. a, b, c своими значениями сравнить эти значения между собой и вывести на экран минимальное значение.

Информатика

Ответы

magichands68
Var a,b,c: integer; begin write('a=');   readln(a); write('b=');   readln(b); write('c=');   readln(c); if a< b then writeln('min=',a) else begin if b< c then writeln('min=',b) else writeln('min=',c); end; readln; end.
alenkadon6
// pascalabc.net 3.1, сборка 1201 от 18.03.2016 begin   var a,b: real;   write('введите два числа через пробел: ');   read(a,b);   if a> b then writeln(a,'> ',b,', максимум равен ',a)   else       if a< b then writeln(a,'< ',b,', максимум равен ',b)       else writeln('веденные числа равны') end. тестовые решения: введите два числа через пробел: 36.4 32.15 36.4> 32.15, максимум равен 36.4 введите два числа через пробел: -46.46 -18.54 -46.46< -18.54, максимум равен -18.54 введите два числа через пробел: 38.0 38 веденные числа равны
Anastasiya1537
Pascalabc.net 3.3.5, сборка 1650 от 01.04.2018 внимание! если программа не работает, обновите версию! procedure bubblesort(a: array of integer;       descending: boolean: =false; // нужна ли сортировка по невозрастанию       u: integer: =-1; // начальный индекс       v: integer: =-1); // конечный индекс // простая пузырьковая сортировка элементов с индексами с u по v begin   // обеспечим корректность параметров u и v   if u< 0 then u: =0;   var n: =a.length;   if (v< 0) or (v> =n) then v: =n-1;   if u> v then swap(u,v)   else if u=v then exit;   // собственно, сортировка   if descending then begin // по невозрастанию       for var i: =v-1 downto u do           for var j: =u to i do               if a[j]< a[j+1] then swap(a[j],a[j+1])       end   else begin       for var i: =v-1 downto u do // по неубыванию           for var j: =u to i do               if a[j]> a[j+1] then swap(a[j],a[j+1])       end end; begin   write(': ');   var a: =arrrandom;   a.println;   var (imin,imax): =(a.indexmin,a.indexmax);   var b: =copy(a);   write('1: '); bubblesort(b,false,0,imax); b.println;   b: =copy(a);   write('2: '); bubblesort(b,false,imin); b.println;   b: =copy(a);   write('3: '); bubblesort(b,true,imax,imin); b.println end. пример   : 70 61 10 72 17 84 19 35 83 47 1: 10 17 61 70 72 84 19 35 83 47 2: 70 61 10 17 19 35 47 72 83 84 3: 70 61 84 72 17 10 19 35 83 47

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить блок схему и написать программу на языке паскаль. a, b, c своими значениями сравнить эти значения между собой и вывести на экран минимальное значение.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Elizavetaborisovna1992
denisovatat7
nikitavertiev98400
Rudakova_Yana
akopovarch
Zhulanova-IP501
Александр734
Andreevich440
mamanger
Yurevich1243
tatur-642789
AHO436
beaevgen711
usmanovayanq2626
palmhold578
▲