ibarskova1542
?>

Написать программу, которая позволяет ввести предложение с клавиатуры и подсчитать при этом, сколько раз вы нажали на клавиши клавиатуры, до тех пор, пока не нажали на клавишу. желательно использовать цикл while или repeat/until. буду )

Информатика

Ответы

fmba18
Var k,n,i,s: integer; beginreadln(k,n); for i: =0 to n do  s: =s+k+i; writeln(s)end.var k,n,i,s: integer; beginreadln(k,n); for i: =0 to n do  s: =s+k+i; writeln(s/(n+1))end.var r,n,i,p: integer; beginreadln(r,n); p: =1; for i: =0 to r do  p: =p*(n+i); writeln(p)end.var r,i,p,x: integer; beginreadln(r); x: =1; for i: =1 to r do  begin  x: =x*i;   p: =p+x;   end; writeln(p)end.var r,i,p,x: integer; beginreadln(r); p: =1; for i: =1 to r do  begin  x: =x+i;   p: =p*x;   end; writeln(p)end.var m,n,t,i: integer; beginreadln(t); writeln('n': 3,'m': 5); for i: =1 to (t div 2) do  begin  n: =i*2;   m: =sqr(n)-n;   writeln(n: 3,m: 5);   end; end.var    y,m,n,i: integer;     x: real; beginreadln(n,m); writeln('y': 3,'x': 10); for i: =1 to m do  begin  y: =n*i;   x: =sqr(y)*(sqr(y)-y)/y;   writeln(y: 3,x: 10);   end; end.
Сергеевна-Иван1045

const n = 10; //кол-во элементов в массиве

var i, sum, proiz: longint;    

a: array [1..n] of longint;

begin sum: =0; proiz: =1;    

  for i : = 1 to n do   

  begin     

  a[i] : = random(10)+1; //заполнение массива     

  write(a[i], ' '); //вывод   

  end;    

writeln;  

  for i : = 1 to n do   

  begin       

  sum : = sum + a[i]; //сумма     

  proiz : = proiz * a[i]; //произведение

    end;   writeln('сумма ',sum);    

  writeln('произведение ',proiz);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая позволяет ввести предложение с клавиатуры и подсчитать при этом, сколько раз вы нажали на клавиши клавиатуры, до тех пор, пока не нажали на клавишу. желательно использовать цикл while или repeat/until. буду )
Ваше имя (никнейм)*
Email*
Комментарий*