antonkovalev89
?>

Написать программу к на паскале расчитать какую массу соли и воды надо взять для приготовления раствора массой m грамм с массовой долей соли w%, w=m(соли)/m, m(соли)=w*m, m(воды)=m-m(соли

Информатика

Ответы

centrprof20
Var m, w: real; begin       read(m, w);       write('salt: ', m * w / 100, '; water: ', m - m * w / 100); end.
Kubataeva Nikolaevich1389
Тексты вводятся в память компьютера с клавиатуры. на клавишах написаны привычные нам буквы, цифры, знаки препинания и другие символы. в оперативную память они в двоичном коде. это значит, что каждый символ представляется 8-разрядным двоичным кодом. кодирование заключается в том, что каждому символу ставится в соответствие уникальный десятичный код от 0 до 255 или соответствующий ему двоичный код от 00000000 до 11111111. таким образом, человек различает символы по их начертанию, а компьютер - по их коду. удобство побайтового кодирования символов очевидно, поскольку байт - наименьшая адресуемая часть памяти и, следовательно, процессор может обратиться к каждому символу отдельно, выполняя обработку текста. с другой стороны, 256 символов – это вполне достаточное количество для представления самой разнообразной символьной информации. теперь возникает вопрос, какой именно восьмиразрядный двоичный код поставить в соответствие каждому символу. понятно, что это дело условное, можно придумать множество способов кодировки. все символы компьютерного алфавита пронумерованы от 0 до 255. каждому номеру соответствует восьмиразрядный двоичный код от 00000000 до 11111111. этот код просто порядковый номер символа в двоичной системе счисления.
Shamil
Program question; var     a: string;     b: integer; begin       writeln('сколько тебе лет? : ');       readln(b);       if b > 17 then begin                                   writeln('в каком институте ты учишься? : ');                                   readln(a);                                   writeln(a, ' хороший институт');                                   writeln('до следующей встречи! ');                             end           else       if b < = 17 then begin                                   writeln('в какой школе ты учишься? ');                                   readln(a);                                   writeln(a, ' не плохая школа');                                   writeln('до следующей встречи! ');                                   end; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу к на паскале расчитать какую массу соли и воды надо взять для приготовления раствора массой m грамм с массовой долей соли w%, w=m(соли)/m, m(соли)=w*m, m(воды)=m-m(соли
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

БеляковаСтаниславовна
Хромов1501
topsalon
moonligh3560
Natysya7777
lor005148
Матвеев
bristolhouse20151001
sharkova1443
nyuraborova89
MikhailovnaAnastasiya
Klochkov malakhov1974
olqa27
Aleksandrovna370
Jannadon77