maroseyka
?>

Написать программу в паскале. : на плоскости даны 2 точки а (х1; у2) и в (х2; у2), определить какая из них находится дальше от начала координат. я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Информатика

Ответы

dimari81

program prog; var x1,x2,y1,y2,i,b: integer; begin; writeln('введите 4 точки: x1, y1; x2, y2'); readln(x1,y1,x2,y2); i: =abs(x1+y1); b: =abs(x2+y2); if i=b then writeln('координаты находятся на одной точке') else beginif i> b then writeln('первая координата дальше') else writeln('вторая координата дальше'); end; end.

secretary

var c,i,z: integer;

    mass,a: array[1..20] of integer;

    q: real;

begin

  writeln('элементы массива: ');

  for i: =1 to 20 do

  begin

    mass[i]: =random(11);

    write(mass[i],' ');

  end;

  writeln;

  write('c=');

  readln(c);

  write('числа превосходящие с:   ');

  for i: =1 to 20 do  

  if (mass[i]> c) then

  begin

    inc(z);

    a[z]: =mass[i];

    write(mass[i],' ');

  end;  

  for i: =1 to z do

  begin

    q: =q+a[i];

  end;

  writeln;

  write('среднее арифметическое этих чисел=',q/z);

end.

abrolchik8511

пк, так называемый компьютер. но что влияет на работу этой машины?

схема компа не так сложна. процессор это мозг, он обрабатывает информацию. видеокарта, она выводит изображение на экран и обеспечивает плавность картинки,например в играх. жёсткий диск на нём хранится информация, есть 2 типа hdd и sdd, первый более дешевый, но второй ускоряет систему(например запуск приложений) , но ssd более дорогой.

оперативная память, на ней лежат функция поддержки работающих приложений, ее надо не так много. а также кулера которые обеспечивают охлаждение.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в паскале. : на плоскости даны 2 точки а (х1; у2) и в (х2; у2), определить какая из них находится дальше от начала координат. я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

yyyaga
re-art
aleksey270593
Станислав Роман994
KononovaMaiorov453
mitin228133770
A2017
tihonovrv477
kotikdmytriy11
Yelfimova-andrei
yaudo47
d43irina
kifstd
zinasekina4
Мамедов