Mbkozlov6
?>

Составить программу именно в №3 последовательно вводятся n целых чисел. сосчитать сколько из них с первым числом.

Информатика

Ответы

elenaneretina
Var
k,n,p1: integer;
begin
writeln('Vvedite chislo');
readln(p1);
n:=0;
repeat
writeln('Vvedite chislo');
readln(k);
if (k=p1) then
n:=n+1;
until k<>-100
Write('Kol-vo sovpadeniy = ',n);
end.
галина
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,c):=ReadReal3('Введите стороны треугольника:');
  if (a+b>c) and (a+c>b) and (b+c>a) then begin
    var alpha:=ArcCos((b*b+c*c-a*a)/(2*b*c));
    var beta:=ArcCos((a*a+c*c-b*b)/(2*a*c));
    var gamma:=Pi-alpha-beta;
    var max:=Max(Max(alpha,beta),gamma);
    var d:=max-Pi/2;
    if abs(d)<=1e-12 then Writeln('Треугольник прямоугольный')
    else if d<0 then Writeln('Треугольник остроугольный')
    else Writeln('Треугольник тупоугольный')
    end
  else Writeln('Треугольник не существует')
end.

Примеры
Введите стороны треугольника: 3.54 5.18 8.32
Треугольник тупоугольный

Введите стороны треугольника: 30 40 50
Треугольник прямоугольный
Gpack54
#include <iostream>
#include <ctime>
#include <cmath>

using namespace std;

struct VERT // структура для вершины многоугольника
{
  int x;
  int y;
};

// Модуль числа
int Modul( int a )
{
  return (a > 0 ? a : -a);
}

// Длина отрезка через координаты
float Len( int x1, int y1, int x2, int y2 )
{
  return sqrt((x1 - x2) * (x1 - x2) + (y1 - y2) * (y1 - y2));
}

int main ()
{
  /// ЗАДАНИЕ 1 ///
  const int N = 3;
  int arr[N];
  float mid = 0;

  // Установка "зерна" для случайных чисел
  srand(time(NULL));
  // Заполнение массива случайными числами и суммирование
  for (int i = 0; i < N; i++)
    arr[i] = rand() % 100, mid += Modul(arr[i]);

  // Вычисление среднего арифм.
  mid /= M;

  /// ЗАДАНИЕ 2 ///
  
  const int V = 3; // количество вершин многоугольника
  VERT vert[V]; // массив вершин многоугольника

  cout << "Введите координаты вершин (x y): " << endl;
  for (int i = 0; i < V; i++)
  {
    cout << i + 1 << ": ";
    cin >> vert[i].x >> vert[i].y;
  }

  // Вычисление периметра
  float per = 0;
  for (int i = 0; i < V - 1; i++)
    per += Len(vert[i].x, vert[i].y, vert[i + 1].x, vert[i + 1].y);

  cout << "Периметр = " << per << endl;

  return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу именно в №3 последовательно вводятся n целых чисел. сосчитать сколько из них с первым числом.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Ямпольский
галина
dianakryukova00
Бурмистрова-Ирина660
olgakuz00261
oliayur4encko
balabinatanya7174
annanudehead1426
ПаршинАндрей1928
ganzashop
Freelifecool797
карпова581
Tatarnikova1507
Yuliya Aleksandr282
gurina50
▲