ortopediya
?>

Написать программу на паскале: среди 10 целых положительных и отрицательных чисел: 1. найти максимальное и минимальное значения. 2. среднее арифметическое среди трехзначных, оканчивающихся на 1 и кратных 7.

Информатика

Ответы

master-lamaster
Var   i, e, min, max, s, n: integer;   c: real; begin   min : = 32767; max : = -32768; s : = 0; n : = 0;   write('введите 10 чисел через пробел ');   for i : = 1 to 10 do   begin       read(e);       if max < e then max : = e;       if min > e then min : = e;       if (e > = 100) and (e < = 999) then           if (i mod 10 = 1) and (i mod 7 = 0) then           begin n : = n + 1; s : = s + i end   end;   writeln('max=', max, ', min=', min);   if n > 0 then writeln('искомое среднее равно ', s / n: 0: 5)   else writeln('нет трехзначных чисел, оканчивающихся на 1 и кратных 7') end.
Светлана
Program   aliona; const n=10; var a : array[1..n] of inreger; min,max,i: integer; begin randomize; for i : =1 to n do begin a[i]: =random(100)+1; write(' ',a[i]); end; min: =a[1]; for i: =1 to n do  if a[i]< a[1] then a[i]: =min; max: =a[1]; for i : =1 to n do  if a[i]> a[1] then max: =a[i]; writeln('min=',min,'max=',max); readln; end,
NikolayGoncharov
Var a,z,s,i,m: integer; begin readln(a); s: =0; z: =a; for i: =1 to 3 do begin s: =s+(z mod 10); z: =z div 10; end; if s mod 2 = 0 then writeln('1. верно')else writeln('1. неверно'); z: =a; s: =z mod 10; z: =z div 10; m: =0; for i: =1 to 2 do begin if s < z mod 10 then begin m: =1; break;   end else begin s: =z div 10; z: =z div 10; end; end; if m = 0 then writeln('2. верно')else writeln('2. неверно'); z: =a; m: =0; for i: =1 to 3 do begin if z mod 10 = 5 then begin m: =1; break; end else begin z: =z div 10; end; end; if m = 1 then writeln('3. верно')else writeln('3. неверно'); if a mod 10=7 then writeln('4. верно')else writeln('4. неверно'); end.
starh
Program treugolnik; uses crt; var a,h,s: real; begin clrscr;           write('основание a = ');           readln(a);           write('высота h = ');           readln(h);           writeln;           if (a< =0) or (h< =0) then           writeln('значения не могут быть отрицательными или равняться нулю')           else                     begin           s: =(1/2)*a*h;           writeln('площадь треугольника s = ',s);           end;           readln; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на паскале: среди 10 целых положительных и отрицательных чисел: 1. найти максимальное и минимальное значения. 2. среднее арифметическое среди трехзначных, оканчивающихся на 1 и кратных 7.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Vuka91
lechic3
Решетникова
rechkai64
Vip2002www86
klimenko05
targovich
kitoova
Zuriko1421
Shcherbakov_Artur1781
menesmir
Golubitskaya378
lebedevevgen
ogonizoloto
tanias
▲