#include <iostream>
#include <locale>
#include <ctime>
#include <cstdio>
#include <malloc.h>
#include <cstdlib>
using namespace std;
int main()
{
srand(time(NULL));
setlocale(LC_ALL, "Russian");
int A, X;
bool c = false;
cout << "Введите количество элементов в массиве" << endl;
cin >> A;
int* massive = (int*)malloc(A * sizeof(int));
for (int i = 0; i < A; i++) {
massive[i] = rand() % 6;
cout << massive[i];
}
cout << "\nВведите какое число надо найти"<<endl;
cin >> X;
for (int i = 0; i < A; i++) {
if (massive[i] == X) {
cout << "A[" << i << "] = " << X << endl;
c = true;
}
}
if (c == false)
cout << "\nНе найдено" << endl;
return 0;
}
Поделитесь своими знаниями, ответьте на вопрос:
Нужно написать программу в паскале найти наименьшее общее кратное n натуральных чисел, используя алгоритм евклида.