Объяснение:
Колонна, состоящая из тринадцати роботов, движется со скоростью 4 см/с. Когда первый робот колонны поравнялся с роботом-инспектором, то робот – инспектор поехал вдоль колонны со скоростью 60 дм/мин, а достигнув её конца, развернулся и вернулся к первому роботу в колонне. Скорость колонны и робота-инспектора постоянны. Длина колонны роботов равна 2 м 10 см. Определите, какой путь проедет робот-инспектор, пока он снова нагонит первого робота в колонне. Временем на разворот можно пренебречь. ответ дайте в дециметрах. В ответ запишите только число.
#include <iostream>
#include<vector>
using namespace std;
int square(int x){
for (int i = 1; i <= 45; ++i){
if (i * i <= x){
continue;
}
return (i - 1) * (i - 1);
}
}
int main()
{
int x, y, xwas, ywas, xywas;
cin >> x >> y;
xwas = square(x);
ywas = square(y);
xywas = square(x + y);
if (xwas + ywas < xywas){
cout << "Petya gives paint to Vasya";
}
else if (xwas + ywas == xywas){
cout << "Equal";
}
else {
cout << "Petya leaves paint to himself";
}
return 0;
}
Объяснение:
Поделитесь своими знаниями, ответьте на вопрос: