aluka
?>

Решить в pascal abc. : составьте программу, утраивающую каждую букву в заданной строке.

Информатика

Ответы

чухловина209
Var s,ns: string; i: integer; begin write('введите строку символов: '); readln(s); ns: =''; for i: =1 to length(s) do ns: =ns+s[i]+s[i]+s[i]; writeln('новая строка:   ',ns); end.
abramovae
1. переведем  271 из 8-ой в 10-ую = 2*8^2 + 7*8^1 + 1 = 128 + 56 + 1 = 185. переведем  11110100 из 2-ой в 10-ую = 2^7 + 2^6 + 2^5 + 2^4 + 2^2 = 128 + 64 + 32 + 16 + 4 = 244.185 + 244 = 429. в 16: 429/16 = 26 (ост: 13 = d); 26 / 16 = 1 (ост 10 = a).  ответ: 1ad.  2. 19 из 10-ой переведём в 6-ую = 31. также переведём 33 из 10-ой в 6-ую = 53.перечислим все наборы: 33 34 35 40 41 42 43 44 45 50 51 52 53.  считаем тройки и получаем их количество - 6.  3. 49[10cc] = 100[x cc]. распишем 100 и получим = 1*x^2 + 0*x^1 + 0*x^0 = x^2. => 49 = x^2; x = 7.ответ: 7.  4. переведём число 30 из 10-ой в 4-ую сс и получим: 132. нам надо найти числа, которые оканчиваются на 31. значит все последующие разряды будут x. x31 < 132. если x = 0, то будет следующее число 031, оно меньше 132 и значит подходит. если x = 1, то будет число 131 и оно также подходит. все последующие число не подходят, поэтому ответ только два числа.  5. долго делать это, чем смог, ; ) 
Shcherbinin KOLIChEVA
Uses crt; var x,y,a,b,h: real; begin       write('a: '); readln(a);       write('b: '); readln(b);       write('h: '); readln(h);       clrscr;       writeln('     x       y');       x: =a;       while x< =b do begin             y: =sin(x)-cos(x);             writeln(x: 7: 2,' ',y: 7: 2);             x: =x+h;       end; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить в pascal abc. : составьте программу, утраивающую каждую букву в заданной строке.
Ваше имя (никнейм)*
Email*
Комментарий*