Станиславович1830
?>

Строка является палиндромом, если слева направо и справа налево она читается одинаково, например "кабак", "боб", "asdfggf' dsa". составьте алгоритм и напишите программу, определяющую, является ли строка палиндромом.

Информатика

Ответы

oserdyuk41
Program gt; var a,b: string; l,i: integer; begin readln(a); l: =length(a); b: =''; for i: =l downto 1 do b: =b+a[i]; if(a=b)then writeln('yes')else writeln('no'); end.
Ioanova Korneeva1093

program cikli;

unit math;

var

  i,n,s,p: integer;

  a: array[1..20]of integer;

begin

  writeln('исходный массив: ');

  for i: =1 to 20 do begin

  a[i]: =randomrange(1,20);

  writeln(' элемент ',i,' =  ',a[i]);

  end;

  writeln('сумму и произведения скольки первых чисел вы хотите посчитать? ');

  readln(n);

  s: =0; p: =1;

//цикл с параметром

  for i: =1 to n do begin

  s: =s+a[i];

  p: =p*a[i];

  end;

writeln('цикл с параметром');

writeln('сумма первых ',n,' чисел = ',s);

writeln('произведения первых ',n,'чисел = ',p);

 

//цикл с предусловием

i: =1; p: =1; s: =0;

while i< > n do begin

  s: =s+a[i];

  p: =p*a[i];

  i: =i+1;

end;

writeln('цикл с предусловием');

writeln('сумма первых ',n,' чисел = ',s);

writeln('произведения первых ',n,'чисел = ',p);

 

//цикл с постусловием

i: =0; s: =0; p: =1;

repeat

  i: =i+1;

  s: =s+a[i];

  p: =p*a[i];

until i=n;

writeln('цикл с постусловием');

writeln('сумма первых ',n,' чисел = ',s);

writeln('произведения первых ',n,'чисел = ',p);

end.

fancy-decor67
Const n=10; var i,j,k,m,buf: integer; a: array[1..n,1..n]of integer; begin     for i: =1 to n do         begin             writeln;                 for m: =1 to n do                     begin                         a[i,m]: =random(20);                         write(a[i,m]: 4);                     end;         end; writeln; writeln('k,j ? '); readln(k,j);     for m: =1 to n do       begin           buf: =a[k,m];           a[k,m]: =a[j,m];           a[j,m]: =buf;         end; for i: =1 to n do     begin         writeln;           for m: =1 to n do               write(a[i,m]: 4);     end; end.                  

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Строка является палиндромом, если слева направо и справа налево она читается одинаково, например "кабак", "боб", "asdfggf' dsa". составьте алгоритм и напишите программу, определяющую, является ли строка палиндромом.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

minchevaelena23
andrewshilin1334
stachevay-lera
Ivanovich-A.V
sisychev
aninepp
orbbsvsupply
laktionova-natal
sav4ukoxana7149
Shishkinna2002
rusvicktor
pashyanaram
Ludmila777020
kirillreznikov
marinadetsad