yuda12
?>

Дано натуральное число. определить количество его нечетных делителей. написать программу паскаль)

Информатика

Ответы

DudukinSerega2507834
Var n,i,k: integer; begin   read(n);   for i: =1 to n do     if (n mod i = 0) and (i mod 2 < > 0) then k: =k+1;   writeln(k); end.
silantyevevgeny
C# int min = 1000; int max = -1; int sum = 0; int [] mass = new int [12]; random rnd = new random(); for (int i = 0; i < mass.length; i++) {       mass[i] = rnd.next(10, 31);       console.writeline(mass[i]); } for (int i = 0; i < mass.length; i++) {       if (mass[i] > max)       {           max = mass[i];       }       else if (mass[i] < min)       {           min = mass[i];       } } sum = max + min; console.writeline("summ = " + sum); 1) заводим массив в 12 элементов 2) заполняем целыми числами от 10 до 30 3) выводим массив 4) ищем максимум, пробегая for'ом по массиву, сверяем в if'е max с элементом 5) как в 4 пункте, только ищем минимум 6) после for'а считаем сумму max и min 7) выводим сумму сорян, на паскале не могу с массивами, не люблю их там.
Узлиян Фурсов1488
Ориента́ция , в классическом случае  — выбор одного класса  систем координат, связанных между собой «положительно» в некотором определённом смысле. каждая система задает ориентацию, определяя класс, к которому она принадлежит,  колонки  — как правило, стереофоническая  акустическая система,  размеры одежды   — некоторый буквенный или цифровой код, соответствующий определённым линейным параметрам человеческого тела либо его частей, для которого (которых) предназначена данная деталь одежды. для выбора подходящей тому или иному человеку одежды и обуви производителями используются системы обозначений размеров. в большинстве случаев размер наносится на бирку, прикрепленную к одежде, а в случае обуви он может находиться на подошве или стельке.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано натуральное число. определить количество его нечетных делителей. написать программу паскаль)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

nikiforovako76
Ivan1568
Chistova-Dmitrii1162
Mariya694
Salkinserg
semenovakotya577
sergei-komissar8475
efimov33
gurman171
Nastyakarysheva8750
Vasilevna_Utenkova651
kirycha-2000719
Александрович
Ильдар-Кугай
servik78