tomogradandrey
?>

9 класс. Написать программу, блок-схему и таблицу изменения значений, используя цикл с постусловием: выброс вредных веществ в атмосферу составил Х тонн. Каждые сутки количество вредных веществ снижается в К раз. Через сколько суток количество ВВ составит норму У? X=567.Y=4 K=2, 6

Информатика

Ответы

Chistov9721209
Var
 K:array[1..2,1..13]  of integer;
 i,j,ind,x,y:integer;
 MAX:real;
 function RAST(x1,x2,y1,y2:integer):real;
  begin
   RAST:=sqrt(sqr(x2-x1)+sqr(y2-y1));
  end;
begin
 MAX:=-2*sqr(-10-1);
 randomize;
 writeln('Исходные точки:');
 for j:=1 to 13 do
  begin
    writeln('Точка № ',j,', с координатами(X,Y)');
    for i:=1 to 2 do 
      begin
        K[i,j]:=random(110) - 10;
        write(K[i,j],'  ');
      end;
    writeln;
   end;
 for i:=1 to 13 do
   if RAST(0,K[1,i],0,K[2,i])>MAX
    then
      begin
         MAX:=RAST(0,K[1,i],0,K[2,i]);
         x:=K[1,i];
         y:=K[2,i];
         ind:=i;
      end;
writeln('Номер точки: ',ind,'  Координаты: ',x,' ; ',y);
end.
  
   

7.4. описать массив из тридцати записей—точек на плоско- сти. заполнить его случайно выбранными коор

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

9 класс. Написать программу, блок-схему и таблицу изменения значений, используя цикл с постусловием: выброс вредных веществ в атмосферу составил Х тонн. Каждые сутки количество вредных веществ снижается в К раз. Через сколько суток количество ВВ составит норму У? X=567.Y=4 K=2, 6
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

aregaa
LesnovaVeronika1830
Николаевна_Анна670
vadim330
tsatskina857
Ka-shop2791
Игорь Андрей
Алёна Геннадьевна98
татьяна1245
hamelleon43
aci2003
solonataly5
Валиахметова
kristinagaspa62
betepah
▲