Nikolaevich
?>

Составить программу для решения следующей : дана длина ребра куба.найти объем куба и площадь его боковой поверхности.

Информатика

Ответы

Zhulanova-IP501
Var a,v,s: real; begin write('введите длину ребра: '); readln(a); v: =a*a*a; s: =4*a*a; writeln('v=',v); writeln('s=',s); end.
Yurok9872

Ну начнем с того, что твоя функция ничего не возвращает, она выводит на экран информацию. Второй косяк в том, что функция isdigit() проверяет всю строку, то есть, при строке с одними цифрами твоя программа даст верный ответ.

Исправить максимально просто, нам нужно проверить каждый символ строки, если встречаем хоть 1 цифру, то возвращаем true, а если не встретим в строке цифр - false.

Максимально простой вариант для новичка, скорее всего, такой:

def number(x):

  for i in x:

      if i.isdigit():

          return True

  return False

print(number('xx'))

kruttorg

Файлдық вирустар көбінесе бағдарламалардың орындалатын модульдеріне енеді (бағдарлама іске қосылатын файлдар), бұл оның жұмысына әсер ететін, бағдарлама іске қосылған сәтте оларды іске қосуға мүмкіндік береді. Әдетте, файлдық вирустар операциялық жүйеге немесе бағдарламалық жасақтама кітапханаларына, орындалатын пакеттік файлдарға, Windows тізілім файлдарына, сценарий файлдарына және драйвер файлдарына енуі мүмкін. Инъекцияны шабуыл жасалған файлдың кодын өзгерту арқылы немесе оның өзгертілген көшірмесін жасау арқылы жүзеге асыруға болады. Осылайша, файлдағы вирус қолданушы немесе ОС өзі бастаған осы файлға қол жеткізген кезде іске қосылады. Файлдық вирустар - компьютерлік вирустың ең көп таралған түрі.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу для решения следующей : дана длина ребра куба.найти объем куба и площадь его боковой поверхности.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

obar1
Anatolevich667
Dragun1684
Александр Сергей
katrinasvr
Inozemtseva Korolev1271
Алена-Петрова285
Lebedeva1577
Vorotko814
Анатольевич-Фатима
алексей_Цуканов
buff-studio
impulsmc715
ibzaira
Ferrigen