lsuvorova1987
?>

Несложная по программированию (можно на любом языке): вася решил заняться торговлей рыбой. с методов машинного обучения он предсказал цены на рыбу на n дней вперёд. он решил, что в один день он купит рыбу, а в один из следующих дней — продаст (то есть совершит или ровно одну покупку и продажу или вообще не совершит покупок и продаж, если это не принесёт ему прибыли к сожалению, рыба — товар скоропортящийся и разница между номером дня продажи и номером дня покупки не должна превышать k. определите, какую максимальную прибыль получит вася. формат ввода в первой строке входных данных числа n и k (1 ≤ n ≤ 10000, 1 ≤ k ≤ 100). во второй строке цены на рыбу в каждый из n дней. цена — целое число, которое может находится в пределах от 1 до 109. формат вывода выведите одно число — максимальную прибыль, которую получит вася. пример: : 5 2 1 2 3 4 5 вывод: 2

Информатика

Ответы

впвыпвып-Зуйков629

var i,j,n,k,k1,k2,k3: integer; bb: boolean;

a: array of integer;

begin

write('n = ');

readln(n);

if ((n mod 3 = 0) and (n< > 0)) then begin

write('k1 = ');

readln(k1);

write('k2 = ');

readln(k2);

write('k3 = ');

readln(k3);

setlength(a,n);

for i: =0 to n-1 do begin

write('заполним номер ',i+1,' -> ');

readln(a[i]);

end;

i: =0;

while (i< n) do

begin

a[i]: =k1-a[i];

a[i+1]: =k2-a[i+1];

a[i+2]: =k3-a[i+2];

inc(i,3);

end;

write('k = ');

readln(k);

for i: =0 to n-2 do

if (a[i]+a[i+1]> =k) then begin write('в комнатах ',i+1,' и ',i+2,' есть ',a[i]+a[i+1],' свободных мест'); bb: = true; end;

if (bb=false) then writeln(0);

end else writeln('введите число кратное 3 и неравное 0');

readln;

end.

Кашихина
Pascalabc.net 3.4.2, сборка 1843 от 24.10.2018 внимание! если программа не работает, обновите версию!

begin

  var a : = arrrandom(15, 0, 150);

  a.println;

  println('max =', a.max);

  println('нечетных: ', a.where(t -> t.isodd).count);

  println('сумма элементов, не превышающих 100: ',

      a.where(t -> t < = 100).sum);

  writeln('число 20 в массиве',a.contains(20)? '': ' не',' встречается');

  a.sort;

  a.println

end.

66 101 58 108 113 143 23 57 36 0 20 27 35 6 138 max = 143 нечетных: 7 сумма элементов, не превышающих 100: 328 число 20 в массиве встречается 0 6 20 23 27 35 36 57 58 66 101 108 113 138 143

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Несложная по программированию (можно на любом языке): вася решил заняться торговлей рыбой. с методов машинного обучения он предсказал цены на рыбу на n дней вперёд. он решил, что в один день он купит рыбу, а в один из следующих дней — продаст (то есть совершит или ровно одну покупку и продажу или вообще не совершит покупок и продаж, если это не принесёт ему прибыли к сожалению, рыба — товар скоропортящийся и разница между номером дня продажи и номером дня покупки не должна превышать k. определите, какую максимальную прибыль получит вася. формат ввода в первой строке входных данных числа n и k (1 ≤ n ≤ 10000, 1 ≤ k ≤ 100). во второй строке цены на рыбу в каждый из n дней. цена — целое число, которое может находится в пределах от 1 до 109. формат вывода выведите одно число — максимальную прибыль, которую получит вася. пример: : 5 2 1 2 3 4 5 вывод: 2
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Дружинин
Викторович Попков
Элементный состав объекта компьютер
Ushakova Sakhno
zbellatriks
Nekrasova
ВалерийАндреевна1788
Avolohova
oalexandrova75
Batrakova-Anna
Алексеевна
YekaterinaAbinskov
ValerevnaRustam1072
es196
EkaterinaSEMENOV702
mail2017