Решите, , хотя бы одну из данных : 1)написать программу, подсчитывающую сумму положительных из трех данных чисел. 2)напечатать те из двузначных чисел которые делятся на 4, но не делятся на 6.
Var n,k,x,i,j: integer; begin write ('введите число: '); readln (n); writeln ('простые делители числа: '); x: =0; for i: =2 to n do begin if n mod i =0 then begin k: =0; for j: =2 to i div 2 do if i mod j=0 then begin k: =1; break end; if k=0 then begin writeln (i); x: =1; end; end; end; if x=0 then writeln ('нет простых делителей'); end. : введите число: 42 простые делители числа: 2 3 7
klodialeit36
23.04.2022
При использовании random() строки получаются редко. можете массив вводить с клавиатуры. const n=5; m=4; var a: array[1..n,1..m] of integer; i,j,max: integer; b1,b2: boolean; begin randomize; writeln('исходный массив: '); for i: =1 to n do begin for j: =1 to m do begin a[i,j]: =random(100); write(a[i,j]: 4); end; writeln; end; max: =-1000; for i: =1 to n do begin b1: =true; b2: =true; for j: =1 to m-1 do begin if a[i,j]< a[i,j+1] then b1: =false; if a[i,j]> a[i,j+1] then b2: =false; end; if b1 or b2 then for j: =1 to m do if a[i,j]> max then max: =a[i,j]; end; if max< > -1000 then writeln('max = ',max) else writeln('в массиве нет строк'); end. пример: 45 34 88 53 2 7 36 71 48 57 28 42 75 61 10 93 15 3 61 54 max = 71
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Решите, , хотя бы одну из данных : 1)написать программу, подсчитывающую сумму положительных из трех данных чисел. 2)напечатать те из двузначных чисел которые делятся на 4, но не делятся на 6.