molchanovaelena284
?>

Составить программу, которая вычисляет произведение сомножителей: (1+1/1)(1+1/4)(1+1/9)(1+1/16)(1+1/25)(1+1/36)… вычисление происходит до тех пор, пока произведение сомножителей не станет больше, чем 3.6. в ответе написать количество сомножителей для данного вычисления. в ответе указать только число, например, 15

Информатика

Ответы

Yuliya Aleksandr686
Var i, ans : integer; pr : real; begin     i : = 1;     pr : = 1;     ans : = 0;     while (pr < = 3.6) do begin         pr *= (1 + 1 / (i * i));         i : = i + 1;           ans : = ans + 1;     end;     writeln(ans); end.48 сомножителей
bakerkirill
// pascalabc.net 3.1, сборка 1172 от 19.02.2016 begin   var s: =readinteger('n=').tostring.joinintostring('');   writeln('цифр в числе- ',s.length);   writeln('сумма цифр- ',s.select(d-> integer.parse();   writeln('последняя цифра- ',s.last);   writeln('первая цифра- ',s.first);   writeln('предпоследняя цифра- ',s[s.length-1]);   var m: =readinteger('m=');   write('сумма ',m,' последних цифр числа- ');   writeln(s.skip(s.length-m).select(d-> integer.parse();   write('цифра 3 в запись числа ');   if pos('3',s)> 0 then writeln('входит')   else writeln('не входит');   writeln('число в обратном порядке- ',s.reverse.joinintostring(''));   writeln('перестановка первой и последней цифр- ',       s.last+copy(s,2,s.length-2)+s.first); end. тестовое решение: n= 1063 цифр в числе- 4 сумма цифр- 10 последняя цифра- 3 первая цифра- 1 предпоследняя цифра- 6 m= 2 сумма 2 последних цифр числа- 9 цифра 3 в запись числа входит число в обратном порядке- 3601 перестановка первой и последней цифр- 3061
avto3132
Program sandp; //название программы var //описание переменных x,y: real; // стороны прямоугольника s: real; // площадь прямоугольника p: real; // периметр прямоугольника procedure rectsp(a,b: real; var s,p: real); //процедура begin s : = a * b; //нахождение площади p : = a + b; //нахождение суммы end; begin //начало основной части программы writeln('введите стороны прямоугольника: '); //диалог с пользователем readln(x,y); //считывание сторон rectsp(x,y,s,p); //вызов процедуры writeln('площадь равна ',s); //вывод площади writeln('периметр равен ',p); //вывод периметра end. //конец программы

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая вычисляет произведение сомножителей: (1+1/1)(1+1/4)(1+1/9)(1+1/16)(1+1/25)(1+1/36)… вычисление происходит до тех пор, пока произведение сомножителей не станет больше, чем 3.6. в ответе написать количество сомножителей для данного вычисления. в ответе указать только число, например, 15
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

inikonovich
serzhs869
dumpler
Ligacom
karien87
vsemvsego306
ganzashop
Yurevna_Kharkchinov1302
Alekseevna
Voshchula David393
innaglobal21
langprint
fialkaflowers77
brendacepedam
Качкова1820