Стадник620
?>

Составить программу подсчитывающую сколько дней в январе было с температурой выше, ниже и равной средней температуре месяца

Информатика

Ответы

metelkin7338
Var  m: array [1..31] of integer; //заполненный массив  sr: real;   //средняя сумма  sum: integer; //сумма всех элементов  i: integer;     a: integer; //значений выше  b: integer; //значений ниже  c: integer; //равных среднему  begin    for i : = 1 to 31 do    sum : = sum + m[i];   sr : = sum / 31;   for i : = 1 to 31 do    if m[i] > sr then        a : = a + 1    else if m[i] < sr then      b : = b + 1    else c : = c + 1;   writeln(a);   writeln(b);     writeln(c); end.
zoyalexa495

5. В КАКОМ ИЗ ПЕРЕЧИСЛЕННЫХ НИЖЕ ПРЕДЛОЖЕНИЙ ПРАВИЛЬНО РАССТАВЛЕНЫ ПРОБЕЛЫ МЕЖДУ СЛОВАМИ И ЗНАКАМИ ПРЕПИНАНИЯ?

а) Пора, что железо:куй, поколе кипит!

б) Пора, что железо: куй, поколе кипит!

в) Пора, что железо: куй , поколе кипит!

г) Пора , что железо : куй , поколе кипит!

6. ТАНЯ НАБИРАЕТ НА КОМПЬЮТЕРЕ ОЧЕНЬ ДЛИННОЕ ПРЕДЛОЖЕНИЕ. КУРСОР УЖЕ ПРИБЛИЗИЛСЯ К КОНЦУ СТРОКИ, А ДЕВОЧКА ДОЛЖНА ВВЕСТИ ЕЩЁ НЕСКОЛЬКО СЛОВ. ЧТО СЛЕДУЕТ ПРЕДПРИНЯТЬ ТАНЕ ДЛЯ ТОГО, ЧТОБЫ ПРОДОЛЖИТЬ ВВОД ПРЕДЛОЖЕНИЯ НА СЛЕДУЮЩЕЙ СТРОКЕ?

а) нажать клавишу Enter

б) перевести курсор в начало следующей строки с курсорных стрелок

в) продолжать набор текста, не обращая внимания на конец строки, — на новую строку курсор перейдёт автоматически

г) перевести курсор в начало следующей строки с мыши

7. РЕДАКТИРОВАНИЕ ТЕКСТА ПРЕДСТАВЛЯЕТ СОБОЙ:

а) процесс внесения изменений в имеющийся текст

б) процедуру сохранения текста на диске в виде текстового файла

в) процесс передачи текстовой информации по компьютерной сети

г) процедуру считывания с внешнего запоминающего устройства ранее созданного текста

8. ПОЛОЖЕНИЕ КУРСОРА В СЛОВЕ С ОШИБКОЙ ОТМЕЧЕНО ЧЁРТОЧКОЙ: МО|АНИТОР. ЧТОБЫ ИСПРАВИТЬ ОШИБКУ, СЛЕДУЕТ НАЖАТЬ КЛАВИШУ:

а) Delete

б) Backspace

в) Delete или Backspace

г) Enter

9. ПОЛОЖЕНИЕ КУРСОРА В СЛОВЕ С ОШИБКОЙ ОТМЕЧЕНО ЧЕРТОЙ: ДИАГРАММ|МА. ЧТОБЫ ИСПРАВИТЬ ОШИБКУ, СЛЕДУЕТ НАЖАТЬ КЛАВИШУ:

а) Delete

б) Backspace

в) Delete или Backspace

г) Enter

10. ЧТОБЫ КУРСОР ПЕРЕМЕСТИЛСЯ В НАЧАЛО ТЕКСТА, НУЖНО НАЖАТЬ:

а) Ctrl + Home

б) Esc

в) Caps Lock

г) Page Up

11. ФРАГМЕНТ ТЕКСТА — ЭТО:

а) слово

б) предложение

в) непрерывная часть текста

г) абзац

12. ЕСЛИ ФРАГМЕНТ ПОМЕСТИЛИ В БУФЕР ОБМЕНА, ТО СКОЛЬКО РАЗ ЕГО МОЖНО ВСТАВИТЬ В ТЕКСТ?

а) один раз

б) это зависит от количества строк в данном фрагменте

в) столько раз, сколько требуется

г) 99 раз, больше не получится

13. В НЕКОМ ТЕКСТОВОМ ПРОЦЕССОРЕ МОЖНО ИСПОЛЬЗОВАТЬ ТОЛЬКО ОДИН ШРИФТ И ДВА ВАРИАНТА НАЧЕРТАНИЯ — ПОЛУЖИРНОЕ НАЧЕРТАНИЕ И КУРСИВ. СКОЛЬКО РАЗЛИЧНЫХ НАЧЕРТАНИЙ СИМВОЛОВ МОЖНО ПОЛУЧИТЬ?

а) 2

б) 3

в) 4

г) 6

14. УКАЖИТЕ «ЛИШНЕЕ»:

а) вставка

б) изменение начертания

в) изменение цвета

г) выравнивание

15. СЧИТАЯ, ЧТО КАЖДЫЙ СИМВОЛ КОДИРУЕТСЯ ОДНИМ БАЙТОМ, ОПРЕДЕЛИТЕ, ЧЕМУ РАВЕН ИНФОРМАЦИОННЫЙ ОБЪЁМ СЛЕДУЮЩЕГО ВЫСКАЗЫВАНИЯ ЖАН-ЖАКА РУССО: ТЫСЯЧИ ПУТЕЙ ВЕДУТ К ЗАБЛУЖДЕНИЮ, К ИСТИНЕ — ТОЛЬКО ОДИН.

а) 92 бита

б) 220 битов

в) 456 битов

г).512 битов

16. СЧИТАЯ, ЧТО КАЖДЫЙ СИМВОЛ КОДИРУЕТСЯ В КОДИРОВКЕ UNICODE, ОЦЕНИТЕ ИНФОРМАЦИОННЫЙ ОБЪЁМ СЛЕДУЮЩЕЙ ФРАЗЫ: В ШЕСТИ ЛИТРАХ 6000 МИЛЛИЛИТРОВ.

а) 1024 байта

б) 1024 бита

в) 512 байтов

г) 512 битов

17. ДЛЯ ХРАНЕНИЯ ТЕКСТА В ВОСЬМИБИТОВОЙ КОДИРОВКЕ ТРЕБУЕТСЯ 10 КБАЙТ. СКОЛЬКО СТРАНИЦ ЗАЙМЁТ ЭТОТ ТЕКСТ, ЕСЛИ НА СТРАНИЦЕ РАЗМЕЩАЕТСЯ 40 СТРОК ПО 64 СИМВОЛА В СТРОКЕ?

а) 4

6)40

в) 160

г) 256________________________________________18. ЭТАП ПОДГОТОВКИ ТЕКСТОВОГО ДОКУМЕНТА, НА КОТОРОМ ОН ЗАНОСИТСЯ ВО ВНЕШНЮЮ ПАМЯТЬ, НАЗЫВАЕТСЯ:

а) копированием

б) сохранением

в) форматированием

г) вводом

19. ТЕКСТ, НАБРАННЫЙ В ТЕКСТОВОМ РЕДАКТОРЕ, ХРАНИТСЯ НА ВНЕШНЕМ ЗАПОМИНАЮЩЕМ УСТРОЙСТВЕ В ВИДЕ:

а) файла

б) таблицы кодировки

в) каталога

г) папки

20. КАКОЙ ИЗ ПРЕДСТАВЛЕННЫХ НИЖЕ ФОРМАТОВ НЕ ОТНОСИТСЯ К ФОРМАТАМ ФАЙЛОВ, В КОТОРЫХ СОХРАНЯЮТ ТЕКСТОВЫЕ ДОКУМЕНТЫ?

д)РРТ

б) DOC

b) ODT

г

martinson
Microsoft qbasic declare function max# (a#, b#) declare function min# (a#, b#) input "a=", a# input "b=", b# input "x=", c# c# = max#(max#(a#, b#), min#(2 * a#, x#)) + 5 print "c="; c# function max# (a#, b#)       if a# > b# then               max# = a#       else               max# = b#       end if end function function min# (a#, b#)       if a# < b# then               min# = a#       else               min# = b#       end if end function

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу подсчитывающую сколько дней в январе было с температурой выше, ниже и равной средней температуре месяца
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

informalla
dimaproh
onboxru16
Алексеевич949
shakmeev
Andreeva
zdanovich90764
di-bobkov1985
margo929
yurassolo747
Карева Даниил1537
Lidburg
Verakravez8790
d892644813661946
mkrtchyananaida6995