edvlwork15
?>

Дано n чисел, сосчитать количество чисел, которые меньше -15, найти сумму кратных 9, но не кратных 6. , напишите программу для pascal и кратко объясните решение, завтра контрольная, а я циклы пропустил по болезни : (

Информатика

Ответы

mirsanm26249

var

  a: integer;   //a - вводимое число

  kol, s: integer;   //kol - количество чисел, кратных 9, но не кратных 6; s - сумма чисел, которые меньше -15

  i: integer;   //переменная для цикла

  n: word;

 

begin

  n: = 0;   //обнуляем счетчик

  s: = 0;   //обнуляем сумму

  writeln('введите число n');

  readln(n);   //вводим n

  for i: = 1 to n do   //вводим число n раз

  begin

    writeln('введите целое число');

    readln(a);

    if a < -15 then kol: = kol + 1;   //если число < 15, то прибавляем к счетчику 1

    if (a mod 9 = 0) and (a mod 6 < > 0) then s: = s + a;   //если число кратно 9, но не кратно 6, то прибавляем это число к сумме

  end;

  writeln('количество чисел, которые меньше -15:   ', kol);   {выводим количество чисел и сумму}

  writeln('сумма чисел, кратных 9, но не кратных 6:   ', s);

end.

os7960

Сейчас в нашей жизни очень много компьютеров. Почти у каждой семьи есть свой персональный компьютер. Как говорят, в мире уже больше миллиарда компьютеров. Итак, мы уже не можем жить без этих умных машин. И я согласна с миллионами пользователями, что компьютеры полезны.

Во-первых, мы получаем очень много информации с компьютеров и Интернета. Это универсальный источник различной информации. И это гораздо удобнее и быстрее, чем искать редкую книгу или спрашивать у учителя совета. Во-вторых, компьютеры предоставляют тебе очень много услуг. Они не только считать, но и создавать фильмы, презентации, сочинять собственные стихи, работать с изображениями и т.д. В-третьих, они общению людей. Например, гораздо быстрее послать письмо по электронной почте, чем отправить ее как в старые времена. И, конечно же, система не сделает никаких ошибок, и письмо придет по правильному адресу, а почтальон может потерять конверт.

Но некоторые говорят, что если ты используешь компьютер, то ты наносишь вред здоровью, а особенно глазам. Однако, я не согласна с таким мнением. Есть специальные правила об использовании компьютера: ты должен регулярно делать передышку и выполнять специальные упражнения для глаз. И, если ты соблюдаешь эти правила, у тебя не будет проблем со здоровьем.

Итого, эти сложные машины нам в нашей каждодневной жизни. И, я думаю, что каждый должен знать как работать с компьютерами, если он хочет идти в ногу со временем.

Объяснение:

Александрович Андреевна
Современный мир полон всяческих новинок: науки, техники, медицины. никогда, наверное, люди не обладали такой суммой знаний в разных областях. удивительные вещи и явления окружают нас.наука придумала массу интересного и полезного. от биоматериалов до искусственной руки. от искусственной почки до контактных линз, которые тренируют ночью глазные мышцы.технологии, созданные самими талантливыми людьми, могут приносить пользу, а могу т и вред. смотря как ими пользоваться. с смартфона, например, можно разводить сплетни.хахахха сплетни)) сам чё нибудь придумаешь хахаа

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано n чисел, сосчитать количество чисел, которые меньше -15, найти сумму кратных 9, но не кратных 6. , напишите программу для pascal и кратко объясните решение, завтра контрольная, а я циклы пропустил по болезни : (
Ваше имя (никнейм)*
Email*
Комментарий*