Olia72
?>

Составить программу для решения : 1)даны действительные, положительные числа x, y, z. выяснить, существует ли треугольник с длинами сторон x, y, z. если треугольник, то является ли он равносторонним? 2)дан одномерный массив. найти количество смен знака между соседними элементами массива. программа -паскаль.

Информатика

Ответы

fednik3337923

var x,y,z: real; beginreadln(x,y,z); if (x< y+z) and (y< x+z) and (z< x+y) then beginif (x=y) and (y=z) then writeln('ravnostoronnii') else writeln('ne ravnostoronnii'); end else writeln('ne vozmojno sostavit'); end.

 

var a: array[1..10]of integer; i,sum: integer; beginfor i: =1 to 10 do readln(a[i]); for i: =1 to 9 do beginif (a[i]> 0) and (a[i+1]< 0) then sum: =sum+1; if (a[i]< 0) and (a[i+1]> 0) then sum: =sum+1; end; writeln(sum); end.

guzelda19904850
A) for i= -15 to do s: s+i; исправленный ответ: for l : = -15 to n do s: =s+l; [! ] a) здесь ошибки заключались в том, что необходимо перед равно писать знак ": ", чтобы присвоить переменной определённое значение. b) for kub: =100/10+11 to 1963 do begin a: =7; end; [! ] b) здесь ошибок нет, но возможно после begin не хватает чего-то дополнительного. c) for mag: =99 dawnto 1 do readl(aa); исправленный вариант: for mag: =99 to 1 do readln(aa); [! ] c) здесь вместо dawnto необходимо писать to. вместо readl необходимо писать readln, т.к. readl - неизвестная функция для pascal abc. d) for bma: =0.5 to 10 dp writedl(k); исправленный вариант: for bma: =0.5 to 10 do writeln(k); [! ] d) здесь необходимо писать вместо dp - do, а вместо writedl - writeln, т.к. это неизвестные функции для pascal abc.
yok887062
## код на ruby 2.2.3p173 def calculate(a, b)       while (b> 0)               a = a * (b % 10)               b = b / 10       end       return a end def zadanie()       args = []       file.open("input.txt", "r") do |file|               line = file.gets               line.split(" ").each {|t| args< < t.to_i}       end       file.open("output.txt", "w") do |file|               file.puts "#{calculate(args[0], args[1])}"       end end # # примеры применения zadanie()

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу для решения : 1)даны действительные, положительные числа x, y, z. выяснить, существует ли треугольник с длинами сторон x, y, z. если треугольник, то является ли он равносторонним? 2)дан одномерный массив. найти количество смен знака между соседними элементами массива. программа -паскаль.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Смирнов_Андрей691
kogakinoa
Konstantin_Vadimirovich
miheev-oleg578
ekasatkina
dsnewline
eisakov86
dumpler
amramzi
olyaartemenko
Bolshakova Shigorina
Tane4ka2110
Константиновна
lazareva
romasmart9