т.к уточнений нет, то написал на pascal самым простеньким методом.
проверьте всё ли тут, что требуется.
var
a,b,c,d,f,g: integer;
begin
writeln('входные данные');
readln(a,b,c);
if (a
d: =a;
if (b
d: =b;
if (c
d: =c;
if (a> b) and (a> c) then
g: =a;
if (b> c) and (b> a) then
g: =b;
if (c> b) and (c> a) then
g: =c;
if (a> d) and (a
f: =a;
if (b> d) and (b
f: =b;
if (c> d) and (c
f: =c;
writeln('результат работы');
writeln(d+' '+f+' '+g);
end.
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали. входные данные в первой строке записаны через пробел размер квадратной матрицы n (количество строк равно количеству столбцов) ( 1 ≤ n ≤ 100 в следующих n строках записаны строки матрицы, в каждой – по n натуральных чисел, разделённых пробелами. выходные данные программа должна вывести матрицу, у которой все элементы выше главной диагонали нулевые, а остальные элементы такие же, как в исходной матрице.