nikolavlad
?>

Нужна : составить программу по которой компьютер угадает число введеное с клавиатуры (с repeat), с пояснениями (игра похожа на игру угадай число, но угадывает компьютер, а мы задумываем)

Информатика

Ответы

Nikolai710

var x,y,a: integer; c: boolean; beginreadln(x); {считываем}

a: =1; repeat

writeln(a,' попытка выбор компьютера пал на - '); y: =random(x)+1; {задаем промежуток рандомом}

write(y); if x=y {сравниваем} then c: =true; {выходим из цикла в случае успеха}until c; {если с=true тогда выход из цикла, иначе крутимся дальше}

writeln('компьютер сделал ',a,' попыток.'); end.

более доработанная и понятная, если возникают какие-то вопросы - пиши в личку.

Abdulganieva1367

Лока́льная вычисли́тельная сеть (ЛВС, локальная сеть; англ. Local Area Network, LAN) — компьютерная сеть, покрывающая обычно относительно небольшую территорию или небольшую группу зданий (дом, офис, фирму, институт). Термин LAN (Local Area Network) также используется в киберспорте и означает, что игроки находятся в одном помещении (арене) и связаны локальной сетью, а не играют из дома через интернет.

Существует несколько объединения компьютеров и сетевого оборудования в единую компьютерную сеть: проводное (витая пара), оптическое (оптоволоконный кабель) и беспроводное (Wi-Fi, Bluetooth) соединения.

1. «Звезда»

Преимущества:

повреждение кабеля одного ПК не сказывается на работе всей сети;

простота подключения, так как рабочая станция должна соединяться только с сервером;

надёжный механизм защиты от несанкционированного доступа;

высокая скорость передачи данных от рабочей станции к серверу.

Недостатки:

невысокая скорость передачи между рабочими станциями;

зависимость мощности всей сети от возможностей сервера;

невозможность коммуникации между отдельными рабочими станциями, минуя сервер.

2. Кольцо

топология кольцо

Преимущества:

существенное сокращение времени доступа к данным;

отсутствие ограничений на длину сети.

Недостатки:

выход из строя одной рабочей станции может привести к отказу всей сети, если не используются специальные переходные соединения;

подключение новых рабочих станций требует отключения всей сети.

Топология сети кольцо

3. Общая шина

Топология шина

Преимущества:

Топология сети общая шина

Топология сети общая шина

1) малый расход кабеля;

2) высокая скорость передачи данных;

3) возможность подключения и отключения рабочий станций без

прерывания работы всей сети;

возможность коммутации рабочий станций без сервера.

Недостатки:

обрыв кабеля приводит к выводу из строя всего участка сети от места разрыва;

возможность несанкционированного подключения к сети, поскольку для увеличения числа рабочих станций нет необходимости прерывания работы сети.

tsypanttn21

1 вариант

Pascal

Var

n,k,i:integer;

X,A,f,C:Real;

begin

k:=1;

Writeln('Введите N');

Readln(n);

Writeln('Введите X');

Readln(x);

Writeln('Введите A');

Readln(a);

F:=(exp(ln(X/A)*1))/1;

for i:=2 to n do begin

  k:=k*i;

  C:=(exp(ln(X/A)*N))/K;

  F:=F+C;

end;

Writeln(F);

end.

2 вариант

var

 X, A, F : Real;

 i, N : Integer;

begin

 Write('n = '); ReadLn(N);

 Write('x = '); ReadLn(X);

 Write('a = '); ReadLn(A);

 F := 1;

 Sum := F;

 for i := 1 to N do

   begin

     F := F * (X / A) / i;

     Sum := Sum + F;

   end;

 WriteLn(Sum:0:5);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужна : составить программу по которой компьютер угадает число введеное с клавиатуры (с repeat), с пояснениями (игра похожа на игру угадай число, но угадывает компьютер, а мы задумываем)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

apromovich1
orbbsvsupply
andrew409
Sadovskaya425
juliaWinter
boyarinovigor
АндреевичОльга641
nailya-abdulova25
Alex-kustov
artem-whitenoise142
in-1973
kononova_Pavel689
zipylin
palchiknr
dlydesertov1
▲