Elshel8694
?>

Составьте программу на языке паскаль для подсчета суммарного числа букв "е" и "о" в строковой величине

Информатика

Ответы

orgot9
Var s: string; j,p: integer; begin readln(s); p: =0; for j: =1 to length(s) do if(s[j]='e')or(s[j]=o)then inc(p); writeln(p); readln end. var s: string; j,e,o: integer; begin readln(s); e: =0; o: =0; for j: =1 to length(s) do begin if s[j]='e' then inc(e); if s[j]=o then inc(o); if o > e then writeln('o'); if o < e writeln('e'); if o=e then writeln('oe'); readln end. счет букв ведется для латинских строчных букв o и e.)
urazmetova

#

# https://pastebin.com/Nasemc0T

#

# Python 3.x

# 1.

# Для теста возьмем конкретную матрицу 8x8.

matrix=[[-35, 115, -45, -25, 1, 83, 13, 53], [119, 128, 31, 124, 66, 126, 63, -1], [-21, 86, 120, 68, 149, 65, -42, 107], [108, 112, 96, 25, 99, 9, 140, 89], [51, 99, 68, 80, 26, 74, 105, -6], [92, 82, 22, 54, 11, 87, -2, -42], [26, -21, 129, 85, 97, 101, 106, 96], [10, -7, -28, 96, 115, 57, -25, 77]]

# Эквивалентно .flatten() для numpy матрицы.

array=list()

for row in matrix: array=array + row

maximum=max(array)

print("#1. Maximum: ", maximum)

# 2.

file="test.txt"

with open(file) as fp:

amount=int(fp.readline())

array=list()

for _ in range(amount):

 digit=int(fp.readline())

 array.append(digit)

 # конец двойно табуляции

maximum=max(array)

print("#2. Maximum: ", maximum)

ukkavtodor6

К сожалению, в процессе революции в науке, происходившей с понятиями времени, энергии, импульса и массы, Эйнштейн, кроме прочего, оставил после себя два различных и противоречащих друг другу определения массы. Из-за этого всё, что мы говорим и имеем в виду, можно интерпретировать двумя очень разными При этом непосредственно в физике никакой путаницы нет. Специалисты точно знают, о чём идёт речь, и знают, как делать предсказания и использовать подходящие уравнения. Весь во только в значении самого слова. Но слова важны, особенно когда мы беседуем о физике с людьми, не являющимися экспертами в этой области, и с учениками, для которых уравнения пока ещё не полностью понятны.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу на языке паскаль для подсчета суммарного числа букв "е" и "о" в строковой величине
Ваше имя (никнейм)*
Email*
Комментарий*