Евгений
?>

Решите на языке паскаль y={x/2, если х< 2} {x^2+1, если x> =2} если можете, то решите с if, then, else

Информатика

Ответы

Tatianarogozina1306
Ямогу сказать, как её можно запрограммировать на . потому что паскаль я не изучала. пиши: if  х< 2, then y=x/2, else y=x^2+1
muz-cd

у тебя уже написан ответ

Объяснение:

В первой строке вводятся целые числа n, m и k (1 ≤ n, m, k ≤ 500) - размеры доски (доска размера n*m) и число фигур на доске.

В следующих k строках выводятся по 2 числа: xi и yi (1 ≤ xi ≤ n, 1 ≤ yi ≤ m) - координаты i-й фигуры.

Формат результата

В первой строке выведите x (0 ≤ x ≤ n*m) - максимальное число слонов, которое вы можете поставить так, чтобы они не били друг друга.

В следующих x строках выведите по 2 числа: xi и yi - координаты i-го слона, которого вы поставили. 1 ≤ ri ≤ n, 1 ≤ ci ≤ m.

Примеры

Входные данные

3 3 0

Результат работы

4

1 1

1 2

1 3

3 2

Входные данные

3 4 2

3 3

2 3

Результат работы

7

1 1

1 2

2 4

1 4

3 2

3 1

3 4

Входные данные

1 3 2

1 2

1 3

Результат работы

1

1 1

dentalfamily
Program z1;   var a: array [1..100] of integer; i,min,n: integer; begin  write('введите размерн массива - ');   readln(n);   randomize;   for i: =1 to n do  begin    a[i]: =random(20)+1;     write (a[i],' ');   end;       for i: =1 to n do    if (a[i] mod 3 = 0) then min: =a[i];       for i: =1 to n do    if ((a[i] mod 3 = 0)and (a[i]< min)) then min: =a[i];   writeln;   writeln(min); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решите на языке паскаль y={x/2, если х< 2} {x^2+1, если x> =2} если можете, то решите с if, then, else
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

uchpaot
bezpalova2013
ЕВгений_денис643
nikolavlad
ryazantseva
snip99
Shlapakov1911aa
Александр Елена1290
potemkin77
ikuvila5484
Melnik Kaveshnikova1746
Романенко
drozd228758
batalerka391
fominovaVladislav1346