ruslan
?>

Дан массив, состоящий из целых чисел. напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками. входные данные сначала задано число n — количество элементов в массиве (1n10000 далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. выходные данные необходимо вывести слово yes, если существует пара соседних элементов с одинаковыми знаками. в противном случае следует вывести слово no.

Информатика

Ответы

mac4roc3781
Var a: array[1..100000] of integer; c,i: integer; begin readln(c); for i: =1 to c do if a[i]> 0 then inc(c); write(c); end.
Никита_Тузов
// pascalabc.net 3.3, сборка 1573 от 04.11.2017 // внимание! если программа не работает, обновите версию! №1 begin   var a: =arrrandom(19,-14,24); a.println;   writeln('п=',a.where(t-> t.iseven).aggregate(int64(,y)-> x*y)) end. пример 3 -4 -9 12 20 19 -8 -10 18 2 2 18 1 -6 -13 18 7 14 11 п=150493593600 №2 begin   var n: =15;   var a: =arrrandom(n,-32,42); a.println;   writeln('ср.арифм: ',range(1,n,2).select(t-> a[t-1]).average: 0: 3) end. пример 18 -29 40 32 23 1 14 15 20 33 -5 -19 3 21 6 ср.арифм: 14.875
ANDREY261965
// pascalabc.net 3.3, сборка 1573 от 04.11.2017 // внимание! если программа не работает, обновите версию! begin   var a: =arrrandom(20,-99,99); a.println;   var (imin,imax): =(a.indexmin,a.indexmax);   writeln('минимальный элемент ',a[imin],', максимальный ',a[imax]);   swap(a[imin],a[imax]); a.println; // меняем местами max и min   swap(a[0],a[a.length-1]); a.println // меняем местами крайние end. пример -45 78 -68 -89 -95 39 55 54 46 69 4 -36 -81 61 47 -76 0 -35 65 -47 минимальный элемент -95, максимальный 78 -45 -95 -68 -89 78 39 55 54 46 69 4 -36 -81 61 47 -76 0 -35 65 -47 -47 -95 -68 -89 78 39 55 54 46 69 4 -36 -81 61 47 -76 0 -35 65 -45

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дан массив, состоящий из целых чисел. напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками. входные данные сначала задано число n — количество элементов в массиве (1n10000 далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. выходные данные необходимо вывести слово yes, если существует пара соседних элементов с одинаковыми знаками. в противном случае следует вывести слово no.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Arsen-araqelyan20164
bronco-s
nchalov2
Дубровская571
oxy03214428
Batrakova-Anna
marinadetsad
Valerevna Tuzova
elena-ppk
rsd737
tobolenecivanov1675
Ivan500
savva-vika
stairov536
Голосова-Лобанов1555