Воронина
?>

1)написать программу, которая определяет четной или нечетной является сумма чисел вводимого трехзначного числаучитель подсказал, что решается через if xmod=0) решите так, чтобы программа была решена не абы-как, а написана правильно и верно, чтобы программа паскаль читала ее на уроке.2)написать программу вычисления факториала числа. (типа 5! =1*2*3*4*5) заранее .

Информатика

Ответы

Ромеовна1527
№1var chislo, sum: integer; begin repeat writeln('введите трехзначное число: '); readln(chislo); until chislo in [100..999]; while chislo > 0 do begin sum : = sum + chislo mod 10; chislo : = chislo div 10; end; if sum mod 2 = 0 then write('число четное') else write('число нечетное'); readln; end. №2var factorial: longint; chislo, i: byte; begin chislo : = 5; factorial : = 1; for i : = 2 to chislo do factorial : = factorial * i; writeln('5! = ', factorial); end.
ivanda
Поиск информации через условие для i элемента в массиве а или "линейный поиск" представим массив а таким образом:   a=[-1, 0, 5, -9, -8, -7, 9, 2, 1, 8] i=  [1,   2, 3, 4,   5,   6,   7, 8, 9, 10]  такие образом для каждого i элемента находим соответствующее значение в массиве а и проверяем на условие  if a[i]< 0a[1]=-1< 0  ? да ->   s: =s+a[i]a[2]=0< 0  ? нет a[3]=5< 0 ? нет  a[4]=-9< 0 ? да ->   s: =s+a[i]a[5]=-8< 0 ? да ->   s: =s+a[i]a[6]=-7< 0 ? да ->   s: =s+a[i]a[7]=9< 0 ? нет a[8]=2< 0 ? нет  a[9]=1< 0 ? нет  a[10]=8< 0 ? нет удовлетворяют условию  a[i]< 0 элементы -1,-9,-8 и -7   их нужно просуммировать при действия  s: =s+a[i] тогда поэтапно параметр s (сумма отрицательных элементов) будет выглядеть так  s=0 s=s+(-1)=0-1=-1 s=s+(-9)=-1-9=-10 s=s+(-8)=-10-8=-18 s=s+(-7)=-18-7=-25 в этом случае s=-25  т.е мы изменяем s прибавляя к нему каждый отрицательный элемент массива поочередно.
rosik76

Условие:

Даны два числа: a и b. Ваша программа должна поменять два числа местами, если a < b, после чего вывести их.

#include <iostream>

#include <clocale>

using namespace std;

int main()

{

   setlocale(LC_ALL,"Russian");

   int a, b;

   cout << "Введите a, b: ";

   cin >> a >> b;

   if (a < b)

   {

       swap(a, b);

   }

   cout << a << " " << b;

}

Объяснение:

#include <iostream>  // Библиотека ввода-вывода

#include <clocale>  // Библиотека для локализации (возможно, будет работать без нее)

using namespace std;  // Пространство имен

int main()

{

   setlocale(LC_ALL,"Russian");  // Локализация (возможно, будет работать без нее)

   int a, b;  // Создание целочисленных переменных

   cout << "Введите a, b: ";  // Вывод текста в консоль

   cin >> a >> b;  // Вводим с клавиатуры

   if (a < b)  // Если а < b

   {

       swap(a, b);  // Меняем a и b местами

   }

   cout << a << " " << b;  // Вывод а и b через пробел

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1)написать программу, которая определяет четной или нечетной является сумма чисел вводимого трехзначного числаучитель подсказал, что решается через if xmod=0) решите так, чтобы программа была решена не абы-как, а написана правильно и верно, чтобы программа паскаль читала ее на уроке.2)написать программу вычисления факториала числа. (типа 5! =1*2*3*4*5) заранее .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

koptevan6
cheshirsky-kot
annabanova9
vladislavk-market2
Михайловна991
anytkaakk
Galkin683
Irina321t
Климова1317
ooottdi
Кулагина_Владимир1179
Natakarpova75732
Mikhailova
dg9792794674
cometa94558