dpolkovnikov
?>

Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, … остаток от деления х на 2 равен 1. в ответе запишите найденное число без пробелов и знаков препинания.

Информатика

Ответы

sadinuraliev263
Var a,b: integer; begina: =1; while b=0 do begin if (a mod 10=9) and (a mod 9=8) and (a mod 8=7) and (a mod 7=6) and (a mod 6=5) and (a mod 5=4) and (a mod 4=3) and (a mod 3=2) and (a mod 2=1)   and (a mod 1=0) then begin b: =a; end; a: =a+1; end; write(b); end.
vinokurova88251

В введенном промежутке натуральных чисел найти те, количество делителей у которых не меньше введенного значения. Для найденных чисел вывести на экран количество делителей и все делители.

Пользователь вводит числовой промежуток - минимальное (a) и максимальное (b) числа. После этого запрашивается искомое количество делителей.

Во внешнем цикле перебираются натуральные числа от a до b. При этом в конце каждой итерации a увеличивается на 1, тем самым приближаясь к b.

В теле внешнего цикла вводится счетчик (m) количества делителей очередного натурального числа. Далее во внутреннем цикле перебираются числа (i) от 1 до a. Если i делит нацело a, то счетчик увеличивается на 1.

После этого значение счетчика сравнивается с требуемым количеством делителей. Если у очередного натурального числа не меньше делителей, чем требуется, то оно и количество делителей выводятся на экран. После этого в цикле снова ищутся делители, но теперь уже они просто выводятся на экран.

Объяснение:

demakova1969

Поиск...

vfvera2000

18.01.2017

Информатика

5 - 9 классы

ответ дан • проверенный экспертом

Дана блок-схема. Какое значение будет иметь z на выходе, если x=47? (При решении и в ответе округляй до десятых)

1

СМОТРЕТЬ ОТВЕТ

ответ, проверенный экспертом

3,0/5

82

ИнформатикБУ

светило науки

496 ответов

358.4 тыс. пользователей, получивших

x := 47

z := 1

i := 0

1 итерация цикла:

z := (1+47/2)/2 = 12,25 (округляем, получаем 12,2)

i := 0 + 1 = 1

2 итерация цикла:

z := (12,2 + 47/2)/2 = 17,85 (округляем, получаем 17,8)

i := 1 + 1 = 2

3 итерация цикла:

z := (17,8 + 47/2)/2 = 20,65 (округляем, получаем 20,6)

i := 2 + 1 = 3

4 итерация цикла:

z := (20,6 + 47/2)/2 = 22,05 (округляем, получаем 22)

i := 3 + 1 = 4

i < 4 - условие не выполняется, выводим 22

ответ: 22

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, … остаток от деления х на 2 равен 1. в ответе запишите найденное число без пробелов и знаков препинания.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Конычева-музей&quot;260
preida-2
Алексеевич949
vladimir72tatarkov1317
bike-garage8
vadimnechaev23150
СветланаВАЛМОС
murin
Voronov434
Https://imgur.com/a/khJfPrz
cvetyzelen283
nadezhdasvirina
sanyaborisov910067
Aleksei
rubanvladimir374
alvas12828646