boyarinovigor
?>

Составить программу чисел кратных 7 и 11 от 144 до 1000 (найти сумму и их количество) ))

Информатика

Ответы

ragimovelshad

program skype: van4es007; var s,i,d,s1,d1,j: integer; begins: =0; s1: =0; d: =0; d1: =0; for i: =144 to 1000 doif (i mod 7 = 0) then begin s1: =s1+1; s: =s1*7 end; for j: = 144 to 1000 doif (j mod 11 = 0) then begin d1: =d1+1; d: =d1*11 end;

      {sum: =d+s;

      sum1: =d1+s1;

writeln('общая сумма чисел ='sum);   вроде не обязательно}

writeln('общее количество чисел ='sum1); это тоже,если надо то добавь sum и sum1 }

writeln('сумма чисел кртаных 7 =',s); writeln('всего чисел кратных 7,в заданом промежутке =',s1); writeln('сумма чисел кртаных 11 =',d); writeln('всего чисел кратных 11,в заданом промежутке =',s);

readln; end.

katrinasvr

var i,s,n: integer; beginfor i: =144 to 1000 do if (i mod 7=0) or (i mod 11=0) then begin s: =s+i; n: =n+1; end; writeln(s,' ',n); end.

klimovala2
Первая: uses crt; var arr: array[1..100] of integer; n,a,c: integer; begin write('сколько чисел вы хотите ввести? -'); readln(n); for a: =1 to n do begin write('введите ',a,' число: '); readln(arr[a]); end; c: =0; for a: =1 to n do begin if   (arr[a] mod 2< > 0) and (arr[a]< 0) then c: =c+1; end; writeln('в последовательности ',c,' нечетных отрицательных чисел.'); end.вторая: uses crt; var arr: array[1..100] of integer; a,b,c,m: integer; beginwrite('сколько чисел вы хотите ввести? -'); readln(b); for a: =1 to b dobeginwrite('введите ',a, ' число: '); readln(arr[a]); end; for a: =1 to b dobeginm: =arr[a]; for c: =1 to 2 dobeginarr[a]: =m*arr[a]; end; end; for a: =1 to b dobegin  writeln('куб ',a,' введенного вами числа равен: ',arr[a]); end; end.
aleksey7800
Borland pascal 7.01 uses crt; const   nn=20;   mm=20; var   i,j,k,n,m: integer;   c1,c2: string;   c: array[1..mm,1..nn] of integer;   a: array[1..mm*nn] of string[9]; begin   clrscr;   { инициализация }   randomize;   write('введите количество строк и столбцов массива: '); read(m,n);   writeln('*** исходный массив ***');   for i: =1 to m do begin       for j: =1 to n do begin           c[i,j]: =random(51)-25;           write(c[i,j]: 4)       end;       writeln   end;   { формирование одномерного массива }   k: =0;   for i: =1 to m do begin       for j: =1 to n do           if c[i,j]> 0 then begin       inc(k);       str(i,c1); str(j,c2);       a[k]: ='['+c1+','+c2+']'           end;       a[k]: =a[k]+#13+#10   end;   { вывод результатов }   writeln('*** компоненты массива с положительными членами ***');   for i: =1 to k do       if a[i][length(a[i])]=#10 then write(a[i])       else write(a[i],' ');   writeln;   readkey end. тестовое решение: введите количество строк и столбцов массива: 8 10 *** исходный массив ***   25 -22  25    5 -11  -1 -10  -6 -19  -9   24 -19  20 -10 -21  10 -19 -14  -6  14   -25  23 -16  17 -22 -14 -20 -16  -8 -17   -15  25 -24    6  -7  15 -11  14 -20  25     8  12 -17 -21  -3  23  -5    9  25  14   23    6    1 -10    5    9 -19    5 -20  23   -24  13    1  -8 -11 -12  15 -14  -8 -16   13 -18  -2  -8    1  16  -2 -23 -11 -12 *** компоненты массива с положительными членами *** [1,1] [1,3] [1,4] [2,1] [2,3] [2,6] [2,10] [3,2] [3,4] [4,2] [4,4] [4,6] [4,8] [4,10] [5,1] [5,2] [5,6] [5,8] [5,9] [5,10] [6,1] [6,2] [6,3] [6,5] [6,6] [6,8] [6,10] [7,2] [7,3] [7,7] [8,1] [8,5] [8,6]

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу чисел кратных 7 и 11 от 144 до 1000 (найти сумму и их количество) ))
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Витальевна
sychevao19975
toxicfish
gip5362
Lazar
Николаевна1564
helenavalenti2846
gulyaizmailova
Voronov434
sashakrav
zrv85
zhunina71807
Aivazyan
Окунева-Мотова
Astrians