Семеновна-Павел
?>

Написать программу определяющую является ли окружность с радиусом r вписанной или описанной около квадрата

Информатика

Ответы

Zaikinarusina
Var   a,r,rvp,rop: real; begin   write('введите сторону квадрата и радиус окружности: ');   readln(a,r);   rvp: =a/2; rop: =a*sqrt(2)/2;   if r< rvp then writeln('окружность расположена внутри вписанной')   else       if r=rvp then writeln('введен радиус вписанной окружности')       else           if r< rop then writeln('окружность расположена между вписанной и описанной')           else               if r=rop then writeln('введен радиус описанной окружности')               else writeln('окружность расположена вне описанной') end. тестовое решение: введите сторону квадрата и радиус окружности: 8 5 окружность расположена между вписанной и описанной
sve-lysenko
// pascalabc.net 3.3, сборка 1541 от 29.09.2017 // внимание! если программа не работает, обновите версию! begin   var n: =readinteger('n=');   var a: =readarrinteger('введите 25 не повторяющихся чисел: '+newline,25);   var b: =readarrinteger('введите '+n+' не повторяющихся чисел: '+newline,n);   writeln('объединенная последовательность: '); (a+b).println end. пример: n= 8 введите 25 не повторяющихся чисел:   -35 41 42 20 -27 1 35 -11 -24 -33 -45 16 50 -8 26 15 6 -38 32 44 -22 -25 -3 -28 48 введите 8 не повторяющихся чисел:   -14 0 37 5 11 -29 36 -19 объединенная последовательность: -35 41 42 20 -27 1 35 -11 -24 -33 -45 16 50 -8 26 15 6 -38 32 44 -22 -25 -3 -28 48 -14 0 37 5 11 -29 36 -19
mokeevahelena

понятие «информационного ресурса общества» (иро) является одним из ключевых понятий социальной информатики. широкое использование этого понятия началось после выхода в 1984 году книги громова г.р. «национальные информационные ресурсы: проблемы промышленной эксплуатации».

информационный ресурс  - это знания, подготовленные для целесообразного социального использования.

понятие иро, накопленных в обществе знаний, может быть рассмотрено в узком и широком смысле слова.

иро в узком смысле слова – это знания, уже готовые для целесообразного социального использования, то есть отчужденные от носителей и материализованные знания.

иро в широком смысле слова включают в себя все отчужденные от носителей и включенные в информационный обмен знания, существующие как в устной, так и в материализованной форме.

понятие ресурс определяется в словаре языка с.и. ожегова как запас, источник чего-нибудь.

что же касается информационных ресурсов, то это понятие является сравнительно новым. оно еще только начинает входить в жизнь современного общества, хотя в последние годы становится все более употребительным не только в научной , но и в общественно-политической деятельности. причиной этого, безусловно, является информатизация общества, в котором все больше начинает осознаваться особо важная роль информации и научных знаний.

для классификации информационных ресурсов могут быть использованы следующие их наиболее важные параметры:

тематика хранящейся в них информации; форма собственности – государственная (федеральная, субъекта федерации, муниципальная), общественных организаций, акционерная, частная; доступность информации – открытая, закрытая, конфиденциальная; принадлежность к определенной информационной системе – библиотечной,- архивной, научно-технической; источник информации – официальная информация, публикации в сми, статистическая отчетность, результаты социологических исследований; назначение и характер использования информации– массовое региональное, ведомственное; форма представления информации – текстовая, цифровая, графическая, мультимедийная; вид носителя информации – бумажный, электронный.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу определяющую является ли окружность с радиусом r вписанной или описанной около квадрата
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ilez03857
Aleksandr556
zapros
kampina1
sahabiev1987
VASILEVNA
Банова_Елена431
aivia29
daryagulyaeva
ЛаринаЛощаков
tatiana2676
Inozemtseva Korolev1271
rubanvladimir374
avtalux527
tarhan1221