karasev17764
?>

Камень падает в колодец. известно время падения. вычислить глубину колодца. : в тетради выполнить этапы программирования 1-3, после этого написать программу расчета глубины колодца (ввод цифры ноль - конец работы программы) и протестировать ее.

Информатика

Ответы

irina25095462
Var g,t: integer; s: real; begin g: =10; writeln('время падения в секундах равно '); read(t); while t< > 0 do begin s: =(g*sqr(t))/2; writeln('высота колодца равна ',s,' метров.'); writeln('время падения в секундах равно '); read(t); end; end.
Скворцов
Program slon; var a, b, c, d: integer; begin a: =0; b: =0; c: =0; d: =0; while (a< 1) or (a> 8) do begin write ('введите число от 1 до 8, a='); readln (a); end; while (b< 1) or (b> 8) do begin write ('введите число от 1 до 8, b='); readln (b); end; while (c< 1) or (c> 8) do begin write ('введите число от 1 до 8, c='); readln (c); end; while (d< 1) or (d> 8) do begin write ('введите число от 1 до 8, d='); readln (d); end; if abs(a-c)=abs(b-d) then write ('true') else write ('false'); end.
evatautes
1.const   n=10; type vector = array [1..n] of integer; var b: vector;           max : integer; procedure intvector(n: integer; var a: vector); begin    for var i : = 1 to n do    a[i] : = random(100); end; procedure outvector(n: integer; a: vector); begin  for var i : = 1 to n do    begin      write(a[i]: 5); end; end; procedure srav (a: vector; n,g: integer); begin g : = a[1]; for var i: =1 to n do if (g < a[i]) then g: =a[i]; writeln (g); end; begin  intvector(n, b);   writeln;   outvector(n, b );   writeln;     srav(b,n, max);   writeln; end.2.  const  n = 10; type  vector = array [1..n] of integer; var  b: vector;         r,v : real;   procedure intvector(n: integer; var a: vector); begin  for var i : = 1 to n do      a[i] : = random(20); end; procedure outvector(n: integer; a: vector); begin    for var i : = 1 to n do    begin    write(a[i]: 5);     end; end; function srednee(a: vector; n: integer): real; begin  for var i : = 1 to n do    begin    result : = (result + a[i]);     end;   end; function kolvo(a: vector; g: real): real; begin  for var i : = 1 to n do     if (a[i] < (srednee(a, n)/10)) then result : = result + 1; end; begin  intvector(n, b);   writeln;   outvector(n, b );   writeln;   writeln ((srednee(b, n)/10): 5: 3);     r : = kolvo(b, v);   writeln(r); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Камень падает в колодец. известно время падения. вычислить глубину колодца. : в тетради выполнить этапы программирования 1-3, после этого написать программу расчета глубины колодца (ввод цифры ноль - конец работы программы) и протестировать ее.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

shajmasha
guujuu
volkovaoksana19806037
amarantmetall
gameover98
Giurievna1977
u-bhank
uuks2012
IInessa44478
varvara-kulkova
ElenaEgorova1988576
ok-49566
Yarovitsin
Yevgenii1423
PoleshchukTatyana