Shikhova-Vitalii1290
?>

Даны числа a, b, c, d.составьте программу, которая выводит на экран те из них, которые лежат в интервале [-5; 4]

Информатика

Ответы

artem-dom
Program zagadki2; var a, b, c, d: string; label r; begin writeln(', я программа, загаывающая загадки'); writeln('будешь отгадывать ? '); readln(a); if a = 'да' then writeln('зимой и летом одним цветом.') else begin writeln('пока'); goto r; end; readln(b); if b = 'ёлка' then writeln('правильно! ') else begin writeln('нет,попробуй ещё раз'); readln(b); if b = 'ёлка' then writeln('! ') end; writeln('сидит красавица в темнице, а коса на улице.'); readln(c); if c = 'морковь' then writeln('правильно! ') else begin writeln('попробуй ещё раз'); readln(c); if c = 'морковь' then writeln('правильно') end; writeln('не лает, не кусает, да в дом не пускает.'); readln(d); if d = 'замок' then writeln('правильно') else begin writeln('попробуй ещё раз'); readln(d); if d = 'замок' then writeln('правильно'); end; r: end.
bondarenkoss

§1.  о системах счисления.

  n4. развернутая форма записи числа

 

из курса вам известно, что цифры десятичной записи числа – это просто коэффициенты его представления в виде суммы степеней числа – основания системы счисления:

       

      25076 = 2*10000 + 5*1000 + 0*100 + 7*10 + 6*1 = 2*104  +5*103  + 0*102  +7*101+6*100

 

при переводе чисел из десятичной системы счисления в римскую мы и воспользовались этим правилом (444 = 400 + 40 + 4;   2986 = 2000 + 900 + 80 + 6).

при записи чисел значение каждой цифры зависит от ее положения. место для цифры в числе называется разрядом, а количество цифр в числе разрядностью. на самом деле числа можно записывать как сумму степеней не только числа 10, но и любого другого натурального числа, большего 1.

 

определение.  развернутой формой записи числа называется такая запись: а4а3а2а1а0  = а4*q4  + a3*q3  + a2*q2  + a1*q1  + a0*q0  , где а4,а3,а2,а1,а0  –цифры числа, q –основание степени.

 

 

пример1.  получить развернутую форму числа 7512410.

решение:

  а4  = 7, а3  = 5, а2  =1 ,а1  =2, а0  =4,          q=10

 

4 3 2 1 0

75 12410  = 7*104  + 5*103  + 1*102  + 2*101  + 4*100.

 

 

пример2.  получить развернутую форму числа 1123.

решение:

 

2 1 0

1123  = 1*32  + 1*31  +2*30

 

пример3.  получить развернутую  форму числа  176,218.

решение:                     21 0-1-2а8=176, 218=1*82+7*81+6*80+2*8-1+1*8-2  для самостоятельной работы: 1. запишите в развернутом виде числа: а8=143511,62а2=100111а10=143,511а16=1а3,5с12. запишите в свернутой форме число: 9*101+1*100+5*10-1+3*10-2a*162+1*161+c*160+3*16-1

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны числа a, b, c, d.составьте программу, которая выводит на экран те из них, которые лежат в интервале [-5; 4]
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Budanov317
Grishanin
ikalabuhova
Romanovich1658
andreyduborezz2913
shtankosoyuz1629
elenaperemena8
knyazev527
mitin228133770
avetisov-84850
Бабур
rusinfopro
Yekaterina_Popova1413
Иванова
Lorik-lorik29