Var a,b,c: integer; begin a: =19; b: =0; repeat if (a mod 5 = 0) then b: =a+b; a: =a+1; until (a> 52); writeln(b); end.
arteevdimon
14.07.2020
// pascal var sum : integer; i: integer; begin sum : = 0; i : = 19; repeat if i mod 5 = 0 then sum : = sum + i; i : = i + 1; until (i > 51); writeln(sum); end.
alex-kuzora4411
14.07.2020
Впрограмме предполагается, что слова отделяются друг от друга одним пробелом, знаков препинания нет. const m=3; var s: string; sl: array[1..m] of string=('значит', 'вот', 'автомобиль'); n: array[1..m] of integer; i: integer; procedure pr(s1,s2: string; var k: integer); var l,p: integer; begin s1: =' '+s1+' '; l: =length(s2); k: =0; p: =pos(s2,s1); while p> 0 do begin if (s1[p-1]=' ')and(s1[p+l]=' ') then k: =k+1; delete(s1,1,p+l); p: =pos(s2,s1); end; end; begin writeln('введите текст: '); readln(s); for i: =1 to m do begin pr(s,sl[i],n[i]); writeln(sl[i],' - ',n[i]); end; end. пример (слов меньше 40): введите текст: значит так вот автомобиль раз вот автомобиль два вот автомобиль три значит - 1 вот - 3 автомобиль - 3
alekseydovganich6
14.07.2020
Этой программе все равно, сколько слов во фразе и какой они длины. а заодно, ей все равно, сколько между словами // pascalabc.net 3.1, сборка 1230 от 27.04.2016 procedure times(a: array of string; pic: string; var n: integer); begin n: =a.where(s-> s=pic).count end; begin var s: =readlnstring('> ').towords; var k: integer; var w: ='значит'; times(s,w,k); println(k,'-',w); w: ='вот'; times(s,w,k); println(k,'-',w); w: ='автомобиль'; times(s,w,k); println(k,'-',w); end. тестовое решение > вот значит какое дело было ехал по дороге автомобиль и вот стоит человек и думает а что значит слово автомобиль а слово автомобиль это от греческого аутос (сам) и латинского мобилис (подвижный) вот такое это слово 2 - значит 3 - вот 3 - автомобиль
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу с цикла с постусловием (repeat паскаль вычислить сумму чисел в диапазоне от 19 до 51, если они делятся на 5.