georgegradoff122
?>

Спо ! нужно составить программу в паскале условие: даны три числа и нужно доказать что они принадлежат отрезку [е; f]

Информатика

Ответы

GALINAMTO
Uses crt;   var e, f, x, y, z: real;           bol: boolean; begin   clrscr;   write(' e = ');   readln(e);   write(' f = ');   readln(f);   write(' x = ');   readln(x);   write(' y = ');   readln(y);   write(' z = ');   readln(z);   bol: =(x> =e) and (x< =f) and (y> =e) and (y< =f) and (z> =e) and (z< =f);   if bol=true then writeln (' принадлежат ! ')                         else writeln (' ');   readln; end.
kareeva
(пишу про язык си/си++) зависит от ситуации.например при создании динамического массива типа char он забивается абсолютно случайными значениями и для их перебора будет лучше присвоить всем элементам такого массива 0 как будто каждый элемент это конец строки (сделать это можно используя функцию после заполнить этот массив буквами (закинуть текст например при std: : cin. и тогда мы сможем перебрать этот массив циклом пример: for (int i = 0; str[i] ! = 0; ++i){} где str[] это динамический массив.еще один случай.иногда вместо простой инициализации переменной нам нужно присвоить ей любое значение (иначе может не скомпилироваться т.к. там будет лежать не понятно что).так же и с единицей.
ShALIGINA
//написано на (си/си++) #include < iostream> #include < stdio.h> int main(){ setloca le(lc_all,""); int x,y; std: : cout < < "введите x: "; std: : cin > > x; std: : cout < < "введите y: "; std: : cin > > y; if (x > y){ /*если x > y то он поменяет их местами*/std: : cout < < "x и y поменяны местами\n"x ^= y; y ^= x; x ^= y;   }else{std: : cout < < "x и y не поменяны местами\n"; }std: : cout < < "x: " < < x < < "   y: " < y; std: : cout < < std: : endl;   system("pause"); return 0; }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Спо ! нужно составить программу в паскале условие: даны три числа и нужно доказать что они принадлежат отрезку [е; f]
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Дарья16
Горина
Immortal3331
Николаевич-Золотая832
askorikova
gaydukov5706
Mikuspavel2
myxa120283
extremhunter
nash-crimea2019
shpakohat
Chuhnin195107364
Vrpeshka
Панков1101
rashodnikoff
▲